Use pkgconfig to detect and configure liblttng-ust
[lttng-tools.git] / tests / utils / testapp / gen-ust-nevents / Makefile.am
index d62c06db99a48cd53ae8a56acf87e01878e99ef9..c20910bd87e91721480d0d22f65b5192cf30f5f2 100644 (file)
@@ -1,15 +1,10 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) -O2 -g
-AM_LDFLAGS =
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
-endif
+AM_CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils \
+       -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-nevents
 gen_ust_nevents_SOURCES = gen-ust-nevents.c tp.c tp.h
-gen_ust_nevents_LDADD = -llttng-ust -lurcu-bp
+gen_ust_nevents_LDADD = $(UST_LIBS) \
+               $(top_builddir)/tests/utils/libtestutils.la \
+               $(DL_LIBS)
 endif
This page took 0.024555 seconds and 5 git commands to generate.