tests: Move to kernel style SPDX license identifiers
[lttng-tools.git] / tests / utils / testapp / userspace-probe-sdt-binary / Makefile.am
index d79ce0ea3fbc9cfc10b66a7c7998f3de78d8ca0c..f12ced228e4611ee6b48361fafe28454b4621b47 100644 (file)
@@ -1,5 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 EXTRA_DIST = foobar_provider.d
+
+# Although this is redundant with the check performed in the parent
+# Makefile.am, this is needed for autotools v1.16+ as BUILT_SOURCES is
+# evaluated for the 'dist' target.
+#
+# It is fine to generate this header in the 'dist' target (when
+# enabled) as it won't be distributed anyhow (it is marked as nodist).
+if TEST_SDT_UPROBE
 BUILT_SOURCES = foobar_provider.h
+endif
 
 noinst_PROGRAMS = userspace-probe-sdt-binary
 userspace_probe_sdt_binary_SOURCES = userspace-probe-sdt-binary.c sema.h sema.c
@@ -26,10 +37,14 @@ libzzz_la_CFLAGS = -I$(abs_builddir)
 libzzz_la_LDFLAGS = -module -shared -avoid-version -rpath $(abs_builddir)/.libs/
 nodist_libzzz_la_SOURCES = $(abs_builddir)/foobar_provider.h
 
+dtrace_verbose = $(dtrace_verbose_@AM_V@)
+dtrace_verbose_ = $(dtrace_verbose_@AM_DEFAULT_V@)
+dtrace_verbose_0 = @echo "  DTRACE  " $@;
+
 foobar_provider.h: foobar_provider.d
-       dtrace -s $< -o $@ -h
+       $(dtrace_verbose)$(DTRACE) -s $< -o $@ -h
 
 foobar_provider.o: foobar_provider.d
-       dtrace -s $< -o $@ -G
+       $(dtrace_verbose)$(DTRACE) -s $< -o $@ -G
 
 CLEANFILES = foobar_provider.h
This page took 0.024655 seconds and 5 git commands to generate.