Add build system, remove dependency on glib, add TAP library
[argpar.git] / tests / Makefile.am
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644 (file)
index 0000000..fa84fc1
--- /dev/null
@@ -0,0 +1,15 @@
+SUBDIRS = tap
+
+AM_CPPFLAGS = \
+       -I$(top_srcdir) \
+       -I$(top_srcdir)/tests/tap \
+       $(GLIB_CFLAGS)
+
+noinst_PROGRAMS = test_argpar
+test_argpar_SOURCES = test_argpar.c
+test_argpar_LDADD = \
+       $(top_builddir)/tests/tap/libtap.la \
+       $(top_builddir)/argpar/libargpar.la \
+       $(GLIB_LIBS)
+
+TESTS = test_argpar
This page took 0.023405 seconds and 4 git commands to generate.