Port: built-in plugins support for the macOS linker
[babeltrace.git] / cli / Makefile.am
index 3cd2a1168bf9c6aa760be97bb5d559672170d71a..195c878ad0b748a001a8a0e62a352370c49bc8dd 100644 (file)
@@ -63,7 +63,7 @@ if ENABLE_BUILT_IN_PLUGINS
 # binary that are filled by plugin objects. If the linker discards those
 # symbols because the CLI does not use them directly, the CLI reports
 # no plugins found (plugins are effectively not embedded).
-pluginarchive = -Wl,--whole-archive,$(PLUGINS_PATH)/$(1)/.libs/babeltrace-plugin-$(1).a,--no-whole-archive
+pluginarchive = $(LD_WHOLE_ARCHIVE)$(PLUGINS_PATH)/$(1)/.libs/babeltrace-plugin-$(1).a$(LD_NO_WHOLE_ARCHIVE)
 
 # Built-in plugins
 babeltrace_bin_LDFLAGS += $(call pluginarchive,ctf)
This page took 0.023958 seconds and 4 git commands to generate.