fix: add .a of the ctf writer plugin in Makefile
[babeltrace.git] / converter / Makefile.am
index b7e126458b3c43d5ef09c5d6a71f136c207ef659..262214f7cc8999548395e59dcefc31c9028e04c1 100644 (file)
@@ -4,7 +4,9 @@ AM_LDFLAGS = -lpopt
 bin_PROGRAMS = babeltrace babeltrace-log
 
 babeltrace_SOURCES = \
-       babeltrace.c
+       babeltrace.c \
+       babeltrace-cfg.c \
+       babeltrace-cfg.h
 
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
@@ -23,6 +25,10 @@ if ENABLE_DEBUG_INFO
 babeltrace_LDADD += $(top_builddir)/lib/libdebug-info.la
 endif
 
+if BUILT_IN_PLUGINS
+babeltrace_LDFLAGS += -Wl,--whole-archive,$(top_builddir)/plugins/ctf/.libs/libbabeltrace-plugin-ctf.a,$(top_builddir)/plugins/text/.libs/libbabeltrace-plugin-ctf-text.a,$(top_builddir)/plugins/muxer/.libs/libbabeltrace-plugin-muxer.a,$(top_builddir)/plugins/writer/.libs/libbabeltrace-plugin-ctf-writer.a,--no-whole-archive
+endif
+
 babeltrace_log_SOURCES = babeltrace-log.c
 
 babeltrace_log_LDADD = \
This page took 0.022704 seconds and 4 git commands to generate.