Handle system and home plugin paths
[babeltrace.git] / converter / Makefile.am
index a0eafaa05ab00fb3b1d8f41f5886e0070db50656..4be27f987271b9a3128c303f4f0147c00e7dfd14 100644 (file)
@@ -1,4 +1,5 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include \
+               -DINSTALL_LIBDIR=\"$(libdir)\"
 AM_LDFLAGS = -lpopt
 
 bin_PROGRAMS = babeltrace babeltrace-log
@@ -26,7 +27,7 @@ babeltrace_LDADD += $(top_builddir)/lib/libdebug-info.la
 endif
 
 if BUILT_IN_PLUGINS
-babeltrace_LDFLAGS += -Wl,--whole-archive,$(top_builddir)/plugins/ctf/.libs/libbabeltrace-plugin-ctf.a,$(top_builddir)/plugins/text/.libs/libbabeltrace-plugin-ctf-text.a,$(top_builddir)/plugins/muxer/.libs/libbabeltrace-plugin-muxer.a,--no-whole-archive
+babeltrace_LDFLAGS += -Wl,--whole-archive,$(top_builddir)/plugins/ctf/.libs/libbabeltrace-plugin-ctf.a,$(top_builddir)/plugins/text/.libs/libbabeltrace-plugin-ctf-text.a,$(top_builddir)/plugins/muxer/.libs/libbabeltrace-plugin-muxer.a,$(top_builddir)/plugins/writer/.libs/libbabeltrace-plugin-ctf-writer.a,--no-whole-archive
 endif
 
 babeltrace_log_SOURCES = babeltrace-log.c
This page took 0.023086 seconds and 4 git commands to generate.