Handle system and home plugin paths
[babeltrace.git] / converter / Makefile.am
index b7e126458b3c43d5ef09c5d6a71f136c207ef659..4be27f987271b9a3128c303f4f0147c00e7dfd14 100644 (file)
@@ -1,10 +1,13 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include \
+               -DINSTALL_LIBDIR=\"$(libdir)\"
 AM_LDFLAGS = -lpopt
 
 bin_PROGRAMS = babeltrace babeltrace-log
 
 babeltrace_SOURCES = \
-       babeltrace.c
+       babeltrace.c \
+       babeltrace-cfg.c \
+       babeltrace-cfg.h
 
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
@@ -23,6 +26,10 @@ if ENABLE_DEBUG_INFO
 babeltrace_LDADD += $(top_builddir)/lib/libdebug-info.la
 endif
 
+if BUILT_IN_PLUGINS
+babeltrace_LDFLAGS += -Wl,--whole-archive,$(top_builddir)/plugins/ctf/.libs/libbabeltrace-plugin-ctf.a,$(top_builddir)/plugins/text/.libs/libbabeltrace-plugin-ctf-text.a,$(top_builddir)/plugins/muxer/.libs/libbabeltrace-plugin-muxer.a,$(top_builddir)/plugins/writer/.libs/libbabeltrace-plugin-ctf-writer.a,--no-whole-archive
+endif
+
 babeltrace_log_SOURCES = babeltrace-log.c
 
 babeltrace_log_LDADD = \
This page took 0.02626 seconds and 4 git commands to generate.