converter: parse 1.x and 2.0 options
[babeltrace.git] / converter / Makefile.am
index 1a6c0daff58c6f5794ce85973c9a835ffe4433ed..5909e2a3a7ff2dc7b412b0567d3b4cde183bc206 100644 (file)
@@ -4,12 +4,14 @@ AM_LDFLAGS = -lpopt
 bin_PROGRAMS = babeltrace babeltrace-log
 
 babeltrace_SOURCES = \
-       babeltrace.c
+       babeltrace.c \
+       babeltrace-cfg.c \
+       babeltrace-cfg.h
 
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-babeltrace_LDFLAGS = $(LD_NO_AS_NEEDED)
+babeltrace_LDFLAGS = -Wl, $(LD_NO_AS_NEEDED), -export-dynamic
 babeltrace_LDADD = \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la \
@@ -17,8 +19,7 @@ babeltrace_LDADD = \
        $(top_builddir)/formats/ctf-text/libbabeltrace-ctf-text.la \
        $(top_builddir)/formats/ctf-metadata/libbabeltrace-ctf-metadata.la \
        $(top_builddir)/formats/bt-dummy/libbabeltrace-dummy.la \
-       $(top_builddir)/formats/lttng-live/libbabeltrace-lttng-live.la \
-       $(top_builddir)/plugins/libbabeltrace-plugin.la
+       $(top_builddir)/formats/lttng-live/libbabeltrace-lttng-live.la
 
 if ENABLE_DEBUG_INFO
 babeltrace_LDADD += $(top_builddir)/lib/libdebug-info.la
This page took 0.024157 seconds and 4 git commands to generate.