converter: parse 1.x and 2.0 options
[babeltrace.git] / converter / Makefile.am
index 47693f5af6fd6c016c7379b36a66cd0e164c4816..5909e2a3a7ff2dc7b412b0567d3b4cde183bc206 100644 (file)
@@ -4,12 +4,14 @@ AM_LDFLAGS = -lpopt
 bin_PROGRAMS = babeltrace babeltrace-log
 
 babeltrace_SOURCES = \
-       babeltrace.c
+       babeltrace.c \
+       babeltrace-cfg.c \
+       babeltrace-cfg.h
 
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-babeltrace_LDFLAGS = $(LD_NO_AS_NEEDED)
+babeltrace_LDFLAGS = -Wl, $(LD_NO_AS_NEEDED), -export-dynamic
 babeltrace_LDADD = \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la \
This page took 0.023772 seconds and 4 git commands to generate.