Add CTF Writer implementation
[babeltrace.git] / formats / ctf / writer / Makefile.am
diff --git a/formats/ctf/writer/Makefile.am b/formats/ctf/writer/Makefile.am
new file mode 100644 (file)
index 0000000..84ac03d
--- /dev/null
@@ -0,0 +1,22 @@
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+
+noinst_LTLIBRARIES = libctf-writer.la
+
+libctf_writer_la_SOURCES = \
+       writer.c \
+       clock.c \
+       stream.c \
+       event-types.c \
+       event-fields.c \
+       event.c \
+       functor.c
+
+libctf_writer_la_LIBADD = \
+       $(top_builddir)/lib/libbabeltrace.la
+
+if BABELTRACE_BUILD_WITH_LIBUUID
+libctf_writer_la_LIBADD += -luuid
+endif
+if BABELTRACE_BUILD_WITH_LIBC_UUID
+libctf_writer_la_LIBADD += -lc
+endif
This page took 0.022442 seconds and 4 git commands to generate.