configure: re-enable '-Wmissing-field-initializers'
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index e427ef61e892997740b4b5e7f87aea3c972286d5..4be841442aa4134eea3979c21367e796ea09f5bd 100644 (file)
@@ -122,6 +122,9 @@ WARN_CFLAGS += -Wno-deprecated-declarations
 # Python 3.11 + gcc 12.2.0 gave warnings of this kind in Python.h.
 WARN_CFLAGS += -Wno-redundant-decls
 
+# For SWIG generated code
+WARN_CFLAGS += -Wno-missing-field-initializers
+
 BUILD_FLAGS=CC="$(CC)" \
                CFLAGS="$(GLIB_CFLAGS) $(AM_CFLAGS) $(CFLAGS) $(WARN_CFLAGS)" \
                CPPFLAGS="$(AM_CPPFLAGS) $(CPPFLAGS) -I$(srcdir)/bt2" \
This page took 0.022827 seconds and 4 git commands to generate.