bt2: compile `native_bt.c` with `-Wno-undef`
[babeltrace.git] / src / bindings / python / bt2 / Makefile.am
index 20f142e4e07004a4e5065c7b4c2e0b95509d5a97..b74821ae8d81445b657c1a4b4734fc04e9eace28 100644 (file)
@@ -120,6 +120,14 @@ WARN_CFLAGS += -Wno-deprecated-declarations
 # Python 3.11 + gcc 12.2.0 gave warnings of this kind in Python.h.
 WARN_CFLAGS += -Wno-redundant-decls
 
+# SWIG 4.2.0 generates:
+#
+#   #if __cplusplus >=201103L
+#
+# ... leading to some `-Wundef` warnings when building the extension as C, where
+# `__cplusplus` is not defined.
+WARN_CFLAGS += -Wno-undef
+
 BUILD_FLAGS=CC="$(CC)" \
                CFLAGS="$(GLIB_CFLAGS) $(AM_CFLAGS) $(CFLAGS) $(WARN_CFLAGS)" \
                CPPFLAGS="$(AM_CPPFLAGS) $(CPPFLAGS) -I$(srcdir)/bt2" \
This page took 0.02292 seconds and 4 git commands to generate.