Re-organize sources
[babeltrace.git] / src / compat / Makefile.am
diff --git a/src/compat/Makefile.am b/src/compat/Makefile.am
new file mode 100644 (file)
index 0000000..040ccc8
--- /dev/null
@@ -0,0 +1,32 @@
+noinst_LTLIBRARIES = libcompat.la
+
+libcompat_la_SOURCES = \
+       logging.c \
+       logging.h \
+       mman.c \
+       mman.h \
+       uuid.c \
+       uuid.h
+
+libcompat_la_LDFLAGS = \
+       $(LD_NO_AS_NEEDED)
+
+if BABELTRACE_BUILD_WITH_MINGW
+libcompat_la_LDFLAGS += -lrpcrt4
+endif
+
+noinst_HEADERS = \
+       bitfield.h \
+       compiler.h \
+       endian.h \
+       fcntl.h \
+       glib.h \
+       limits.h \
+       memstream.h \
+       socket.h \
+       stdio.h \
+       stdlib.h \
+       string.h \
+       time.h \
+       unistd.h \
+       utc.h
This page took 0.023698 seconds and 4 git commands to generate.