Reduce the number of Makefiles in 'src/'
[babeltrace.git] / src / lib / Makefile.am
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
deleted file mode 100644 (file)
index a911381..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# SPDX-License-Identifier: MIT
-
-SUBDIRS = trace-ir prio-heap plugin graph
-
-lib_LTLIBRARIES = libbabeltrace2.la
-
-libbabeltrace2_la_SOURCES = \
-       assert-cond-base.h \
-       assert-cond.h \
-       assert-cond.c \
-       babeltrace2.c \
-       current-thread.c \
-       error.c \
-       error.h \
-       func-status.h \
-       integer-range-set.c \
-       integer-range-set.h \
-       lib-logging.c \
-       logging.c \
-       logging.h \
-       object-pool.c \
-       object-pool.h \
-       object.h \
-       property.h \
-       util.c \
-       value.c \
-       value.h
-
-libbabeltrace2_la_LDFLAGS = \
-       $(AM_LDFLAGS) \
-       $(LT_NO_UNDEFINED) \
-       -version-info $(BABELTRACE_LIBRARY_VERSION)
-
-libbabeltrace2_la_LIBADD = \
-       prio-heap/libprio-heap.la \
-       graph/libgraph.la \
-       plugin/libplugin.la \
-       trace-ir/libtrace-ir.la \
-       $(top_builddir)/src/logging/libbabeltrace2-logging.la \
-       $(top_builddir)/src/common/libbabeltrace2-common.la \
-       $(top_builddir)/src/compat/libcompat.la
-
-if ENABLE_BUILT_IN_PYTHON_PLUGIN_SUPPORT
-libbabeltrace2_la_LIBADD += $(top_builddir)/src/python-plugin-provider/babeltrace2-python-plugin-provider.la
-endif
This page took 0.030337 seconds and 4 git commands to generate.