cpp-common/bt2c: add `format_as()` functions for `Uuid` and `UuidView`
[babeltrace.git] / tests / Makefile.am
index 88c385e00349d3d7d6bf121a0dcbc929f86ee177..6136c771b6d201765150ca83d45b1d302983f888 100644 (file)
@@ -100,8 +100,19 @@ cpp_common_test_c_string_view_SOURCES = \
 cpp_common_test_c_string_view_LDADD = \
        $(COMMON_TEST_LDADD)
 
+noinst_PROGRAMS += \
+       cpp-common/test-uuid
+
+cpp_common_test_uuid_SOURCES = \
+       cpp-common/test-uuid.cpp
+
+cpp_common_test_uuid_LDADD = \
+       $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/cpp-common/vendor/fmt/libfmt.la
+
 TESTS_CPP_COMMON = \
-       cpp-common/test-c-string-view
+       cpp-common/test-c-string-view \
+       cpp-common/test-uuid
 
 TESTS_LIB = \
        lib/test-bt-uuid \
This page took 0.022292 seconds and 4 git commands to generate.