Remove everything related to the `bt2.ctf_writer` Python module
[babeltrace.git] / tests / Makefile.am
index 8d14cef024ce10941745761a8d06d120643218ec..344bc646a9baf6e78b2a19720ebcd21dd552e3dd 100644 (file)
@@ -1,25 +1,48 @@
-SUBDIRS = utils cli lib bindings plugins
-
-EXTRA_DIST = $(srcdir)/ctf-traces/** \
-            $(srcdir)/debug-info-data/** \
-            $(srcdir)/debug-info-data/.build-id/cd/**
+SUBDIRS = utils lib plugins
+
+# Directories added to EXTRA_DIST will be recursively copied to the distribution.
+EXTRA_DIST = $(srcdir)/ctf-traces \
+            $(srcdir)/debug-info-data \
+            bindings/python/bt2/.coveragerc
+
+dist_check_SCRIPTS = \
+       bindings/python/bt2/test_clock_class_priority_map.py \
+       bindings/python/bt2/test_clock_class.py \
+       bindings/python/bt2/test_component_class.py \
+       bindings/python/bt2/test_component.py \
+       bindings/python/bt2/test_connection.py \
+       bindings/python/bt2/test_ctf_writer_clock.py \
+       bindings/python/bt2/test_event_class.py \
+       bindings/python/bt2/test_event.py \
+       bindings/python/bt2/test_field_class.py \
+       bindings/python/bt2/test_field.py \
+       bindings/python/bt2/test_graph.py \
+       bindings/python/bt2/test_message_iterator.py \
+       bindings/python/bt2/test_message.py \
+       bindings/python/bt2/test_packet.py \
+       bindings/python/bt2/test_plugin.py \
+       bindings/python/bt2/test_port.py \
+       bindings/python/bt2/test_query_executor.py \
+       bindings/python/bt2/test_stream_class.py \
+       bindings/python/bt2/test_stream.py \
+       bindings/python/bt2/test_trace_collection_message_iterator.py \
+       bindings/python/bt2/test_trace.py \
+       bindings/python/bt2/test_value.py \
+       bindings/python/bt2/utils.py \
+       python-plugin-provider/bt_plugin_test_python_plugin_provider.py \
+       python-plugin-provider/test_python_plugin_provider.py
 
 TESTS_BINDINGS =
 
-if ENABLE_PYTHON_PLUGINS
-SUBDIRS += python-plugin-provider
-endif
-
 if ENABLE_PYTHON_BINDINGS
-TESTS_BINDINGS += bindings/python/bt2/test_python_bt2 \
-       bindings/python/babeltrace/test_python_babeltrace
+TESTS_BINDINGS += bindings/python/bt2/test_python_bt2
 endif
 
 TESTS_CLI = \
        cli/test_trace_read \
        cli/test_packet_seq_num \
        cli/test_convert_args \
-       cli/intersection/test_intersection \
+       cli/test_intersection \
        cli/test_trace_copy \
        cli/test_trimmer
 
@@ -36,7 +59,6 @@ endif
 
 if ENABLE_PYTHON_BINDINGS
 TESTS_LIB += lib/trace-ir/test_trace_ir
-TESTS_LIB += lib/ctf-writer/test_ctf_writer
 endif
 
 TESTS_PLUGINS =
@@ -53,8 +75,14 @@ endif
 
 if ENABLE_DEBUG_INFO
 TESTS_PLUGINS += \
-       plugins/test_dwarf_complete \
-       plugins/test_bin_info_complete
+       plugins/test_dwarf_i386-linux-gnu \
+       plugins/test_dwarf_powerpc-linux-gnu \
+       plugins/test_dwarf_powerpc64le-linux-gnu \
+       plugins/test_dwarf_x86_64-linux-gnu \
+       plugins/test_bin_info_i386-linux-gnu \
+       plugins/test_bin_info_powerpc-linux-gnu \
+       plugins/test_bin_info_powerpc64le-linux-gnu \
+       plugins/test_bin_info_x86_64-linux-gnu
 endif
 
 TESTS_PYTHON_PLUGIN_PROVIDER =
This page took 0.02502 seconds and 4 git commands to generate.