tests: remove `check` targets in subdirectories
[babeltrace.git] / tests / Makefile.am
index 4bdbedd0ccc496ab11bb1b2164f4eba1be737b3f..796334ffaa616553a6dd765417fddc17ee1d4f5c 100644 (file)
@@ -4,6 +4,71 @@ EXTRA_DIST = $(srcdir)/ctf-traces/** \
             $(srcdir)/debug-info-data/** \
             $(srcdir)/debug-info-data/.build-id/cd/**
 
+TESTS_BINDINGS =
+
 if ENABLE_PYTHON_PLUGINS
 SUBDIRS += python-plugin-provider
+TESTS_BINDINGS += bindings/python/bt2/test_python_bt2
+endif
+
+TESTS_CLI = \
+       cli/test_trace_read \
+       cli/test_packet_seq_num \
+       cli/test_convert_args \
+       cli/intersection/test_intersection \
+       cli/test_trace_copy \
+       cli/test_trimmer
+
+TESTS_LIB = \
+       lib/test_bitfield \
+       lib/test_ctf_writer_complete \
+       lib/test_bt_values \
+       lib/test_ctf_ir_ref \
+       lib/test_bt_ctf_field_type_validation \
+       lib/test_ir_visit \
+       lib/test_bt_notification_heap \
+       lib/test_graph_topo \
+       lib/test_cc_prio_map \
+       lib/test_bt_notification_iterator
+
+if ENABLE_PYTHON_PLUGINS
+TESTS_LIB += \
+       lib/writer/test_ctf_writer_no_packet_context.py \
+       lib/writer/test_ctf_writer_empty_packet.py
+endif
+
+if !ENABLE_BUILT_IN_PLUGINS
+TESTS_LIB += lib/test_plugin_complete
 endif
+
+TESTS_PLUGINS =
+
+if !ENABLE_BUILT_IN_PLUGINS
+TESTS_PLUGINS += plugins/test-utils-muxer-complete
+endif
+
+if ENABLE_DEBUG_INFO
+TESTS_PLUGINS += \
+       plugins/test_dwarf_complete \
+       plugins/test_bin_info_complete
+endif
+
+TESTS_PYTHON_PLUGIN_PROVIDER =
+
+if ENABLE_PYTHON_BINDINGS
+TESTS_PYTHON_PLUGIN_PROVIDER += python-plugin-provider/test_python_plugin_provider
+endif
+
+TESTS = $(TESTS_BINDINGS) $(TESTS_CLI) $(TESTS_LIB) $(TESTS_PLUGINS) \
+       $(TESTS_PYTHON_PLUGIN_PROVIDER)
+
+define check_target
+check-$(1):
+       $(MAKE) $(AM_MAKEFLAGS) TESTS="$2" check
+endef
+
+$(eval $(call check_target,bindings,$(TESTS_BINDINGS)))
+$(eval $(call check_target,cli,$(TESTS_CLI)))
+$(eval $(call check_target,lib,$(TESTS_LIB)))
+$(eval $(call check_target,plugins,$(TESTS_PLUGINS)))
+$(eval $(call check_target,python-plugin-provider,$(TESTS_PYTHON_PLUGIN_PROVIDER)))
This page took 0.024691 seconds and 4 git commands to generate.