tests: fix Python plugin provider tests on Windows
[babeltrace.git] / tests / Makefile.am
index 4bb87daa69a8e1058e635aec202c2a80be876d08..7ed754157910d84454677b04032e76241bfe196f 100644 (file)
@@ -15,6 +15,7 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_field_class.py \
        bindings/python/bt2/test_field.py \
        bindings/python/bt2/test_graph.py \
+       bindings/python/bt2/test_integer_range_set.py \
        bindings/python/bt2/test_message_iterator.py \
        bindings/python/bt2/test_message.py \
        bindings/python/bt2/test_packet.py \
@@ -76,10 +77,11 @@ TESTS_PLUGINS = \
 if !ENABLE_BUILT_IN_PLUGINS
 if ENABLE_PYTHON_BINDINGS
 TESTS_PLUGINS += plugins/src.ctf.fs/query/test_query
+endif
 
 if ENABLE_DEBUG_INFO
-TESTS_PLUGINS += plugins/flt.lttng-utils.debug-info/test_lttng_utils_debug_info
-endif
+TESTS_PLUGINS += \
+       plugins/flt.lttng-utils.debug-info/test_succeed
 endif
 endif
 
@@ -114,8 +116,9 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             BT_TESTS_AWK_BIN="$(AWK)" \
             BT_TESTS_GREP_BIN="$(GREP)" \
             BT_TESTS_PYTHON_BIN="$(PYTHON)" \
+            BT_TESTS_PYTHON_CONFIG_BIN="$(PYTHON_CONFIG)" \
             BT_TESTS_SED_BIN="$(SED)" \
-            $(SHELL) $(top_srcdir)/config/tap-driver.sh
+            $(SHELL) $(srcdir)/utils/tap-driver.sh
 
 TESTS_NO_BITFIELD = \
        $(TESTS_BINDINGS) \
This page took 0.023279 seconds and 4 git commands to generate.