cli: handle leftovers in the same loop as components
[babeltrace.git] / tests / Makefile.am
index d004b03ffeb4661c59346821da2edeb2b385cf56..845b9c44a4b31b751f4e8c05f887f8b025ef6d61 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = utils lib bitfield ctf-writer plugins
+SUBDIRS = utils lib bitfield ctf-writer plugins argpar
 
 # Directories added to EXTRA_DIST will be recursively copied to the distribution.
 EXTRA_DIST = $(srcdir)/data \
@@ -16,8 +16,10 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_field.py \
        bindings/python/bt2/test_graph.py \
        bindings/python/bt2/test_integer_range_set.py \
+       bindings/python/bt2/test_interrupter.py \
        bindings/python/bt2/test_message_iterator.py \
        bindings/python/bt2/test_message.py \
+       bindings/python/bt2/test_package.py \
        bindings/python/bt2/test_packet.py \
        bindings/python/bt2/test_plugin.py \
        bindings/python/bt2/test_port.py \
@@ -29,6 +31,7 @@ dist_check_SCRIPTS = \
        bindings/python/bt2/test_trace.py \
        bindings/python/bt2/test_value.py \
        bindings/python/bt2/utils.py \
+       cli/auto-source-discovery/test_auto_source_discovery \
        cli/test_convert_args \
        cli/test_intersection \
        cli/test_output_ctf_metadata \
@@ -46,6 +49,9 @@ if ENABLE_PYTHON_BINDINGS
 TESTS_BINDINGS += bindings/python/bt2/test_python_bt2
 endif
 
+TESTS_ARGPAR = \
+       argpar/test_argpar
+
 TESTS_CLI = \
        cli/test_trace_read \
        cli/test_packet_seq_num \
@@ -99,6 +105,7 @@ endif
 
 if ENABLE_PYTHON_PLUGINS
 if ENABLE_PYTHON_BINDINGS
+TESTS_CLI += cli/auto-source-discovery/test_auto_source_discovery
 TESTS_PLUGINS += plugins/flt.utils.trimmer/test_trimming
 endif
 endif
@@ -116,10 +123,12 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
             BT_TESTS_AWK_BIN="$(AWK)" \
             BT_TESTS_GREP_BIN="$(GREP)" \
             BT_TESTS_PYTHON_BIN="$(PYTHON)" \
+            BT_TESTS_PYTHON_CONFIG_BIN="$(PYTHON_CONFIG)" \
             BT_TESTS_SED_BIN="$(SED)" \
             $(SHELL) $(srcdir)/utils/tap-driver.sh
 
 TESTS_NO_BITFIELD = \
+       $(TESTS_ARGPAR) \
        $(TESTS_BINDINGS) \
        $(TESTS_CLI) \
        $(TESTS_CTF_WRITER) \
@@ -134,6 +143,7 @@ check-$(1):
        $(MAKE) $(AM_MAKEFLAGS) TESTS="$2" check
 endef
 
+$(eval $(call check_target,argpar,$(TESTS_ARGPAR)))
 $(eval $(call check_target,bindings,$(TESTS_BINDINGS)))
 $(eval $(call check_target,bitfield,$(TESTS_BITFIELD)))
 $(eval $(call check_target,cli,$(TESTS_CLI)))
This page took 0.024405 seconds and 4 git commands to generate.