tests: put TESTS list in each Makefile.am
[babeltrace.git] / tests / bin / Makefile.am
index 2bf94246a893e5c03e8283e422514a347eb94e44..97d8eeba4a7f7322d76869e276d0996f2d92203b 100644 (file)
@@ -1,7 +1,15 @@
-noinst_SCRIPTS = test_trace_read test_intersection test_packet_seq_num
-CLEANFILES = $(noinst_SCRIPTS)
-EXTRA_DIST = test_trace_read.in test_intersection.in test_packet_seq_num.in
+SUBDIRS = intersection
+check_SCRIPTS = test_trace_read test_packet_seq_num test_convert_args
 
-$(noinst_SCRIPTS): %: %.in
-       sed "s#@ABSTOPSRCDIR@#$(abs_top_srcdir)#g" < $< > $@
-       chmod +x $@
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
+
+TESTS = test_trace_read \
+       test_trace_read \
+       test_packet_seq_num \
+       test_convert_args \
+       intersection/test_intersection
+
+if USE_PYTHON
+TESTS += intersection/test_multi_trace_intersection.py
+endif
This page took 0.023125 seconds and 4 git commands to generate.