tests/lib: reorganize Makefile.am a bit
[babeltrace.git] / tests / lib / Makefile.am
index 721244fb3e112a78f2e4acc1f89dbf2ceab2e6ab..c462e3c4316c86888dbbac88c98a8be01382e0fd 100644 (file)
@@ -11,24 +11,32 @@ COMMON_TEST_LDADD = \
        $(top_builddir)/src/common/libcommon.la \
        $(top_builddir)/src/logging/liblogging.la
 
+test_bt_values_SOURCES = test-bt-values.c
 test_bt_values_LDADD = $(COMMON_TEST_LDADD) \
        $(top_builddir)/src/lib/libbabeltrace2.la
 
+test_fields_bin_SOURCES = test-fields-bin.cpp
 test_fields_bin_LDADD = $(COMMON_TEST_LDADD) \
        $(top_builddir)/src/lib/libbabeltrace2.la
 
+test_bt_uuid_SOURCES = test-bt-uuid.c
 test_bt_uuid_LDADD = $(COMMON_TEST_LDADD)
 
+test_trace_ir_ref_SOURCES = test-trace-ir-ref.c
 test_trace_ir_ref_LDADD = $(COMMON_TEST_LDADD) \
        $(top_builddir)/src/lib/libbabeltrace2.la \
        $(top_builddir)/src/ctf-writer/libbabeltrace2-ctf-writer.la
 
+test_graph_topo_SOURCES = test-graph-topo.c
 test_graph_topo_LDADD = $(COMMON_TEST_LDADD) \
        $(top_builddir)/src/lib/libbabeltrace2.la
 
+test_simple_sink_SOURCES = test-simple-sink.c
 test_simple_sink_LDADD = $(COMMON_TEST_LDADD) \
        $(top_builddir)/src/lib/libbabeltrace2.la
 
+test_remove_destruction_listener_in_destruction_listener_SOURCES = \
+       test-remove-destruction-listener-in-destruction-listener.c
 test_remove_destruction_listener_in_destruction_listener_LDADD = \
        $(COMMON_TEST_LDADD) \
        $(top_builddir)/src/lib/libbabeltrace2.la
@@ -42,15 +50,6 @@ noinst_PROGRAMS = \
        test-simple-sink \
        test-trace-ir-ref
 
-test_bt_values_SOURCES = test-bt-values.c
-test_fields_bin_SOURCES = test-fields-bin.cpp
-test_simple_sink_SOURCES = test-simple-sink.c
-test_bt_uuid_SOURCES = test-bt-uuid.c
-test_trace_ir_ref_SOURCES = test-trace-ir-ref.c
-test_graph_topo_SOURCES = test-graph-topo.c
-test_remove_destruction_listener_in_destruction_listener_SOURCES = \
-       test-remove-destruction-listener-in-destruction-listener.c
-
 if !ENABLE_BUILT_IN_PLUGINS
 noinst_PROGRAMS += test-plugins test-plugin-init-fail
 SUBDIRS += test-plugins-plugins test-plugin-init-fail-plugin
This page took 0.023244 seconds and 4 git commands to generate.