Tests: add visitor interface test
[babeltrace.git] / tests / lib / Makefile.am
index 976e4cf0baff0c2ddd4c4d935e1bb7e5c27d8050..3d3b215fcb60dad899f1f599c0fbcf85c491dfa1 100644 (file)
@@ -30,8 +30,12 @@ test_bt_ctf_field_type_validation_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
+test_ir_visit_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+
 noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer test_bt_values \
-       test_ctf_ir_ref test_bt_ctf_field_type_validation
+       test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
@@ -39,6 +43,7 @@ test_ctf_writer_SOURCES = test_ctf_writer.c
 test_bt_values_SOURCES = test_bt_values.c
 test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
 test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
+test_ir_visit_SOURCES = test_ir_visit.c
 
 check_SCRIPTS = test_seek_big_trace \
                test_seek_empty_packet \
This page took 0.023383 seconds and 4 git commands to generate.