Tests writer: write a trace defining no packet context
[babeltrace.git] / tests / lib / Makefile.am
index d240cbc0e1d9850078ae502b17a5df362e747845..8fb1910861f11da2b655f6a1b5a163a7d5ced8ee 100644 (file)
@@ -1,3 +1,5 @@
+SUBDIRS = writer
+
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
@@ -9,13 +11,13 @@ noinst_LTLIBRARIES = libtestcommon.la
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
 test_seek_LDFLAGS = $(LD_NO_AS_NEEDED)
-COMMON_TEST_LDADD = $(LIBTAP) libtestcommon.a \
+COMMON_TEST_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
 test_seek_LDADD = $(COMMON_TEST_LDADD)
 
-test_bitfield_LDADD = $(LIBTAP) libtestcommon.a
+test_bitfield_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la
 
 test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
 
@@ -30,9 +32,11 @@ test_ir_visit_LDADD = $(COMMON_TEST_LDADD)
 
 test_trace_listener_LDADD = $(COMMON_TEST_LDADD)
 
+test_bt_notification_heap_LDADD = $(COMMON_TEST_LDADD)
+
 noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer test_bt_values \
        test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
-       test_trace_listener
+       test_trace_listener test_bt_notification_heap
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
@@ -42,6 +46,7 @@ test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
 test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
 test_ir_visit_SOURCES = test_ir_visit.c
 test_trace_listener_SOURCES = test_trace_listener.c
+test_bt_notification_heap_SOURCES = test_bt_notification_heap.c
 
 check_SCRIPTS = test_seek_big_trace \
                test_seek_empty_packet \
This page took 0.024283 seconds and 4 git commands to generate.