Add basic object system tests
[babeltrace.git] / tests / lib / Makefile.am
index 7c96e4ab0b2c0448964feb5e063bca4c51f8f394..cbf40ec96162c77ee5a922c9201957b34d7d6d39 100644 (file)
@@ -20,15 +20,20 @@ test_ctf_writer_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
-noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer
+test_bt_objects_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la
+
+noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer test_bt_objects
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
+test_bt_objects_SOURCES = test_bt_objects.c
 
 SCRIPT_LIST = test_seek_big_trace \
        test_seek_empty_packet \
-       test_ctf_writer_complete
+       test_ctf_writer_complete \
+       test_bt_objects
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
This page took 0.023645 seconds and 4 git commands to generate.