ctf.fs: bt_ctf_notif_iter_create(): assert() that all medops exist
[babeltrace.git] / tests / lib / Makefile.am
index 3d3b215fcb60dad899f1f599c0fbcf85c491dfa1..cd53661eac9d051e58ea1bad50c5c8899c6cafea 100644 (file)
@@ -1,3 +1,5 @@
+SUBDIRS = test-plugin-plugins writer .
+
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
@@ -9,33 +11,39 @@ noinst_LTLIBRARIES = libtestcommon.la
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
 test_seek_LDFLAGS = $(LD_NO_AS_NEEDED)
-test_seek_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la \
+COMMON_TEST_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
+test_seek_LDADD = $(COMMON_TEST_LDADD)
+
 test_bitfield_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la
 
-test_ctf_writer_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la\
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
 
 test_bt_values_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libbabeltrace.la
 
-test_ctf_ir_ref_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+test_ctf_ir_ref_LDADD = $(COMMON_TEST_LDADD)
 
-test_bt_ctf_field_type_validation_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+test_bt_ctf_field_type_validation_LDADD = $(COMMON_TEST_LDADD)
 
-test_ir_visit_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+test_ir_visit_LDADD = $(COMMON_TEST_LDADD)
+
+test_trace_listener_LDADD = $(COMMON_TEST_LDADD)
+
+test_bt_notification_heap_LDADD = $(COMMON_TEST_LDADD)
+
+test_plugin_LDADD = $(COMMON_TEST_LDADD)
+
+test_graph_topo_LDADD = $(COMMON_TEST_LDADD)
+
+test_cc_prio_map_LDADD = $(COMMON_TEST_LDADD)
 
 noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer test_bt_values \
-       test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit
+       test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
+       test_trace_listener test_bt_notification_heap test_plugin test_graph_topo \
+       test_cc_prio_map
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
@@ -44,10 +52,16 @@ test_bt_values_SOURCES = test_bt_values.c
 test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
 test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
 test_ir_visit_SOURCES = test_ir_visit.c
+test_trace_listener_SOURCES = test_trace_listener.c
+test_bt_notification_heap_SOURCES = test_bt_notification_heap.c
+test_plugin_SOURCES = test_plugin.c
+test_graph_topo_SOURCES = test_graph_topo.c
+test_cc_prio_map_SOURCES = test_cc_prio_map.c
 
 check_SCRIPTS = test_seek_big_trace \
                test_seek_empty_packet \
-               test_ctf_writer_complete
+               test_ctf_writer_complete \
+               test_plugin_complete
 
 if ENABLE_DEBUG_INFO
 test_dwarf_LDFLAGS = -static
This page took 0.02343 seconds and 4 git commands to generate.