Add validation/resolving tests
[babeltrace.git] / tests / lib / Makefile.am
index ac6e53cba0d1152a61bb32bc7f62c4a5bbaad072..f1efac690ee76cfe7a9e1e8990a5d6872d450e04 100644 (file)
@@ -27,14 +27,19 @@ test_ctf_ir_ref_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
+test_bt_ctf_field_type_validation_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+
 noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer test_bt_values \
-       test_ctf_ir_ref
+       test_ctf_ir_ref test_bt_ctf_field_type_validation
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 test_bt_values_SOURCES = test_bt_values.c
 test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
+test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
 
 SCRIPT_LIST = test_seek_big_trace \
        test_seek_empty_packet \
This page took 0.022809 seconds and 4 git commands to generate.