tests: normalize names of files and more
[babeltrace.git] / tests / lib / Makefile.am
index c36035f293d72f87e1b9d96f9f3bf514d555adc5..f2c70351290852f7bb0949e6fd9ab890b001219a 100644 (file)
@@ -1,16 +1,22 @@
-SUBDIRS =
+# SPDX-License-Identifier: MIT
+
+SUBDIRS = utils
 
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
 COMMON_TEST_LDADD = \
        $(top_builddir)/tests/utils/tap/libtap.la \
        $(top_builddir)/tests/utils/libtestcommon.la \
+       $(top_builddir)/tests/lib/utils/liblib-utils.la \
        $(top_builddir)/src/common/libbabeltrace2-common.la \
-       $(top_builddir)/src/logging/libbabeltrace2-logging.la
+       $(top_builddir)/src/logging/liblogging.la
 
 test_bt_values_LDADD = $(COMMON_TEST_LDADD) \
        $(top_builddir)/src/lib/libbabeltrace2.la
 
+test_fields_bin_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+
 test_bt_uuid_LDADD = $(COMMON_TEST_LDADD)
 
 test_trace_ir_ref_LDADD = $(COMMON_TEST_LDADD) \
@@ -28,20 +34,22 @@ test_remove_destruction_listener_in_destruction_listener_LDADD = \
        $(top_builddir)/src/lib/libbabeltrace2.la
 
 noinst_PROGRAMS = \
-       test_bt_uuid \
-       test_bt_values \
-       test_graph_topo \
-       test_remove_destruction_listener_in_destruction_listener \
-       test_simple_sink \
-       test_trace_ir_ref
-
-test_bt_values_SOURCES = test_bt_values.c
-test_simple_sink_SOURCES = test_simple_sink.c
-test_bt_uuid_SOURCES = test_bt_uuid.c
-test_trace_ir_ref_SOURCES = test_trace_ir_ref.c
-test_graph_topo_SOURCES = test_graph_topo.c
+       test-bt-uuid \
+       test-bt-values \
+       test-graph-topo \
+       test-fields-bin \
+       test-remove-destruction-listener-in-destruction-listener \
+       test-simple-sink \
+       test-trace-ir-ref
+
+test_bt_values_SOURCES = test-bt-values.c
+test_fields_bin_SOURCES = test-fields-bin.cpp
+test_simple_sink_SOURCES = test-simple-sink.c
+test_bt_uuid_SOURCES = test-bt-uuid.c
+test_trace_ir_ref_SOURCES = test-trace-ir-ref.c
+test_graph_topo_SOURCES = test-graph-topo.c
 test_remove_destruction_listener_in_destruction_listener_SOURCES = \
-       test_remove_destruction_listener_in_destruction_listener.c
+       test-remove-destruction-listener-in-destruction-listener.c
 
 if !ENABLE_BUILT_IN_PLUGINS
 noinst_PROGRAMS += plugin
@@ -51,4 +59,10 @@ plugin_SOURCES = plugin.c
 SUBDIRS += test-plugin-plugins
 endif
 
-dist_check_SCRIPTS = test_plugin
+dist_check_SCRIPTS = test-plugin.sh test-fields.sh
+
+if HAVE_PYTHON
+if DEV_MODE
+SUBDIRS += conds
+endif
+endif
This page took 0.023275 seconds and 4 git commands to generate.