Remove `test_bt_message_iterator`
[babeltrace.git] / tests / lib / Makefile.am
index 01831de3dfb86452bba6c3e39bf652750b37c56d..f66b73ece58d84e00cd86e70e207c5c280e4c2ea 100644 (file)
@@ -1,21 +1,43 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = trace-ir ctf-writer
 
-noinst_LIBRARIES = libtestcommon.a
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
-libtestcommon_a_SOURCES = tap.c tap.h common.c common.h
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
-test_seeks_LDADD = libtestcommon.a \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+libtestcommon_la_SOURCES = common.c common.h
+noinst_LTLIBRARIES = libtestcommon.la
 
-test_bitfield_LDADD = libtestcommon.a
+# -Wl,--no-as-needed is needed for recent gold linker who seems to think
+# it knows better and considers libraries with constructors having
+# side-effects as dead code.
+COMMON_TEST_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la \
+       $(top_builddir)/lib/libbabeltrace.la
 
-noinst_PROGRAMS = test-seeks test-bitfield
+test_bitfield_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la
 
-test_seeks_SOURCES = test-seeks.c
-test_bitfield_SOURCES = test-bitfield.c
+test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
 
-EXTRA_DIST = README.tap runall.sh
+test_bt_values_LDADD = $(COMMON_TEST_LDADD)
 
-check-am:
-       ./runall.sh
+test_trace_ir_ref_LDADD = $(COMMON_TEST_LDADD)
+
+test_graph_topo_LDADD = $(COMMON_TEST_LDADD)
+
+noinst_PROGRAMS = test_bitfield test_ctf_writer test_bt_values \
+       test_trace_ir_ref test_graph_topo
+
+test_bitfield_SOURCES = test_bitfield.c
+test_ctf_writer_SOURCES = test_ctf_writer.c
+test_bt_values_SOURCES = test_bt_values.c
+test_trace_ir_ref_SOURCES = test_trace_ir_ref.c
+test_graph_topo_SOURCES = test_graph_topo.c
+
+check_SCRIPTS = test_ctf_writer_complete
+
+if !ENABLE_BUILT_IN_PLUGINS
+noinst_PROGRAMS += test_plugin
+test_plugin_LDADD = $(COMMON_TEST_LDADD)
+test_plugin_SOURCES = test_plugin.c
+check_SCRIPTS += test_plugin_complete
+SUBDIRS += test-plugin-plugins
+endif
This page took 0.023562 seconds and 4 git commands to generate.