Remove `test_bt_message_iterator`
[babeltrace.git] / tests / lib / Makefile.am
index 2bcc630d6fc0f3479ba2218aa59897dcbc2eb4df..f66b73ece58d84e00cd86e70e207c5c280e4c2ea 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = writer .
+SUBDIRS = trace-ir ctf-writer
 
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
@@ -19,63 +19,25 @@ test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
 
 test_bt_values_LDADD = $(COMMON_TEST_LDADD)
 
-test_ctf_ir_ref_LDADD = $(COMMON_TEST_LDADD)
-
-test_bt_ctf_field_type_validation_LDADD = $(COMMON_TEST_LDADD)
-
-test_ir_visit_LDADD = $(COMMON_TEST_LDADD)
-
-test_bt_notification_heap_LDADD = $(COMMON_TEST_LDADD)
+test_trace_ir_ref_LDADD = $(COMMON_TEST_LDADD)
 
 test_graph_topo_LDADD = $(COMMON_TEST_LDADD)
 
-test_cc_prio_map_LDADD = $(COMMON_TEST_LDADD)
-
-test_bt_notification_iterator_LDADD = $(COMMON_TEST_LDADD)
-
 noinst_PROGRAMS = test_bitfield test_ctf_writer test_bt_values \
-       test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
-       test_bt_notification_heap test_graph_topo \
-       test_cc_prio_map test_bt_notification_iterator
+       test_trace_ir_ref test_graph_topo
 
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 test_bt_values_SOURCES = test_bt_values.c
-test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
-test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
-test_ir_visit_SOURCES = test_ir_visit.c
-test_bt_notification_heap_SOURCES = test_bt_notification_heap.c
+test_trace_ir_ref_SOURCES = test_trace_ir_ref.c
 test_graph_topo_SOURCES = test_graph_topo.c
-test_cc_prio_map_SOURCES = test_cc_prio_map.c
-test_bt_notification_iterator_SOURCES = test_bt_notification_iterator.c
 
 check_SCRIPTS = test_ctf_writer_complete
 
-LOG_DRIVER_FLAGS='--merge'
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
-
-TESTS = test_bitfield \
-       test_ctf_writer_complete \
-       test_bt_values \
-       test_ctf_ir_ref \
-       test_bt_ctf_field_type_validation \
-       test_ir_visit \
-       test_bt_notification_heap \
-       test_graph_topo \
-       test_cc_prio_map \
-       test_bt_notification_iterator
-
-if ENABLE_PYTHON_BINDINGS
-TESTS +=
-       writer/test_ctf_writer_no_packet_context.py \
-       writer/test_ctf_writer_empty_packet.py
-endif
-
 if !ENABLE_BUILT_IN_PLUGINS
 noinst_PROGRAMS += test_plugin
 test_plugin_LDADD = $(COMMON_TEST_LDADD)
 test_plugin_SOURCES = test_plugin.c
-TESTS += test_plugin_complete
 check_SCRIPTS += test_plugin_complete
 SUBDIRS += test-plugin-plugins
 endif
This page took 0.02506 seconds and 4 git commands to generate.