Remove `test_bt_message_iterator`
[babeltrace.git] / tests / lib / Makefile.am
index cbbc5dc407025a25ba44969f27776ead107e396a..f66b73ece58d84e00cd86e70e207c5c280e4c2ea 100644 (file)
@@ -1,4 +1,6 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
+SUBDIRS = trace-ir ctf-writer
+
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
@@ -8,58 +10,34 @@ noinst_LTLIBRARIES = libtestcommon.la
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-test_seek_LDFLAGS = $(LD_NO_AS_NEEDED)
 COMMON_TEST_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
-
-test_seek_LDADD = $(COMMON_TEST_LDADD)
+       $(top_builddir)/lib/libbabeltrace.la
 
 test_bitfield_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la
 
 test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
 
-test_bt_values_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la
-
-test_ctf_ir_ref_LDADD = $(COMMON_TEST_LDADD)
-
-test_bt_ctf_field_type_validation_LDADD = $(COMMON_TEST_LDADD)
+test_bt_values_LDADD = $(COMMON_TEST_LDADD)
 
-test_ir_visit_LDADD = $(COMMON_TEST_LDADD)
+test_trace_ir_ref_LDADD = $(COMMON_TEST_LDADD)
 
-test_trace_listener_LDADD = $(COMMON_TEST_LDADD)
+test_graph_topo_LDADD = $(COMMON_TEST_LDADD)
 
-noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer test_bt_values \
-       test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
-       test_trace_listener
+noinst_PROGRAMS = test_bitfield test_ctf_writer test_bt_values \
+       test_trace_ir_ref test_graph_topo
 
-test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 test_bt_values_SOURCES = test_bt_values.c
-test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
-test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
-test_ir_visit_SOURCES = test_ir_visit.c
-test_trace_listener_SOURCES = test_trace_listener.c
-
-check_SCRIPTS = test_seek_big_trace \
-               test_seek_empty_packet \
-               test_ctf_writer_complete
-
-if ENABLE_DEBUG_INFO
-test_dwarf_LDFLAGS = -static
-test_dwarf_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/lib/libdebug-info.la
-test_dwarf_SOURCES = test_dwarf.c
+test_trace_ir_ref_SOURCES = test_trace_ir_ref.c
+test_graph_topo_SOURCES = test_graph_topo.c
 
-test_bin_info_LDFLAGS = -static
-test_bin_info_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/lib/libdebug-info.la
-test_bin_info_SOURCES = test_bin_info.c
+check_SCRIPTS = test_ctf_writer_complete
 
-noinst_PROGRAMS += test_dwarf test_bin_info
-check_SCRIPTS += test_dwarf_complete test_bin_info_complete
+if !ENABLE_BUILT_IN_PLUGINS
+noinst_PROGRAMS += test_plugin
+test_plugin_LDADD = $(COMMON_TEST_LDADD)
+test_plugin_SOURCES = test_plugin.c
+check_SCRIPTS += test_plugin_complete
+SUBDIRS += test-plugin-plugins
 endif
This page took 0.025178 seconds and 4 git commands to generate.