Implement libcounter
[deliverable/lttng-ust.git] / libcounter / Makefile.am
diff --git a/libcounter/Makefile.am b/libcounter/Makefile.am
new file mode 100644 (file)
index 0000000..9d52b74
--- /dev/null
@@ -0,0 +1,18 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CFLAGS += -fno-strict-aliasing
+
+noinst_LTLIBRARIES = libcounter.la
+
+libcounter_la_SOURCES = \
+       counter.c smp.c smp.h shm.c shm.h shm_internal.h shm_types.h \
+       counter-api.h counter.h counter-internal.h counter-types.h
+
+libcounter_la_LIBADD = \
+       -lpthread \
+       -lrt
+
+if HAVE_LIBNUMA
+libcounter_la_LIBADD += -lnuma
+endif
+
+libcounter_la_CFLAGS = -DUST_COMPONENT="libcounter" $(AM_CFLAGS)
This page took 0.023482 seconds and 5 git commands to generate.