Add CTF enum type support to tracepoint event
[deliverable/lttng-ust.git] / tests / ctf-types / Makefile.am
diff --git a/tests/ctf-types/Makefile.am b/tests/ctf-types/Makefile.am
new file mode 100644 (file)
index 0000000..366870e
--- /dev/null
@@ -0,0 +1,13 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
+
+noinst_PROGRAMS = ctf-types
+ctf_types_SOURCES = ctf-types.c tp.c ust_tests_ctf_types.h
+ctf_types_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
+ctf_types_CFLAGS = -Werror=old-style-definition
+
+if LTTNG_UST_BUILD_WITH_LIBDL
+ctf_types_LDADD += -ldl
+endif
+if LTTNG_UST_BUILD_WITH_LIBC_DL
+ctf_types_LDADD += -lc
+endif
This page took 0.035834 seconds and 5 git commands to generate.