Implement dynamic types, and application context provider support
[deliverable/lttng-ust.git] / tests / test-app-ctx / Makefile.am
diff --git a/tests/test-app-ctx/Makefile.am b/tests/test-app-ctx/Makefile.am
new file mode 100644 (file)
index 0000000..324c2cd
--- /dev/null
@@ -0,0 +1,13 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
+
+noinst_PROGRAMS = hello
+hello_SOURCES = hello.c tp.c ust_tests_hello.h
+hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
+hello_CFLAGS = -Werror=old-style-definition
+
+if LTTNG_UST_BUILD_WITH_LIBDL
+hello_LDADD += -ldl
+endif
+if LTTNG_UST_BUILD_WITH_LIBC_DL
+hello_LDADD += -lc
+endif
This page took 0.037516 seconds and 5 git commands to generate.