SoW-2020-0003: Trace Hit Counters
[lttng-tools.git] / tests / regression / tools / map / Makefile.am
diff --git a/tests/regression/tools/map/Makefile.am b/tests/regression/tools/map/Makefile.am
new file mode 100644 (file)
index 0000000..8fb83c3
--- /dev/null
@@ -0,0 +1,30 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+AM_CPPFLAGS += -I$(top_srcdir)/tests -I$(srcdir)
+
+noinst_SCRIPTS = \
+       map_base_test.sh \
+       test_map_kernel
+
+EXTRA_DIST = \
+       map_base_test.sh \
+       test_map_kernel
+
+if HAVE_LIBLTTNG_UST_CTL
+EXTRA_DIST += test_map_ust
+noinst_SCRIPTS += test_map_ust
+endif
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.025942 seconds and 5 git commands to generate.