SoW-2019-0007-2: Dynamic Snapshot: Triggers send partial event payload with notifications
[lttng-tools.git] / tests / unit / Makefile.am
index e2c57bc8e7d68b28c1b0c3e08c18cd3cec06ce0e..322bdfa7cbc79c44133a6f0f47eb96790fe51f5b 100644 (file)
@@ -17,12 +17,14 @@ TESTS = test_kernel_data \
        test_utils_compat_poll \
        test_string_utils \
        test_notification \
+       test_event_rule \
        test_directory_handle \
        test_relayd_backward_compat_group_by_session \
        ini_config/test_ini_config \
        test_fd_tracker \
        test_uuid \
-       test_buffer_view
+       test_buffer_view \
+       test_event_expr_to_bytecode
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
@@ -41,7 +43,8 @@ noinst_PROGRAMS = test_uri test_session test_kernel_data \
                   test_string_utils test_notification test_directory_handle \
                   test_relayd_backward_compat_group_by_session \
                   test_fd_tracker test_uuid \
-                  test_buffer_view
+                  test_buffer_view test_fd_tracker test_event_rule test_condition \
+                 test_event_expr_to_bytecode
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS += test_ust_data
@@ -61,6 +64,7 @@ SESSIOND_OBJS = $(top_builddir)/src/bin/lttng-sessiond/buffer-registry.$(OBJEXT)
         $(top_builddir)/src/bin/lttng-sessiond/kernel.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/ht-cleanup.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/notification-thread.$(OBJEXT) \
+        $(top_builddir)/src/bin/lttng-sessiond/action-executor.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/lttng-syscall.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/channel.$(OBJEXT) \
         $(top_builddir)/src/bin/lttng-sessiond/agent.$(OBJEXT) \
@@ -107,6 +111,7 @@ test_session_SOURCES = test_session.c
 test_session_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBRELAYD) $(LIBSESSIOND_COMM) \
                     $(LIBHASHTABLE) $(DL_LIBS) -lrt -lurcu-common -lurcu \
                     $(KMOD_LIBS) \
+                    -lmsgpackc \
                     $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                     $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
                     $(top_builddir)/src/common/compat/libcompat.la \
@@ -128,6 +133,7 @@ test_ust_data_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBRELAYD) $(LIBSESSIOND_COMM) \
                      $(LIBHASHTABLE) $(DL_LIBS) -lrt -lurcu-common -lurcu \
                      $(UST_CTL_LIBS) \
                      $(KMOD_LIBS) \
+                     -lmsgpackc \
                      $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                      $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
                      $(top_builddir)/src/common/compat/libcompat.la \
@@ -184,6 +190,14 @@ test_string_utils_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBSTRINGUTILS) $(DL_LIBS)
 # Notification api
 test_notification_SOURCES = test_notification.c
 test_notification_LDADD = $(LIBTAP) $(LIBLTTNG_CTL) $(DL_LIBS)
+#
+# Event rule api
+test_event_rule_SOURCES = test_event_rule.c
+test_event_rule_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
+
+# Condition api
+test_condition_SOURCES = test_condition.c
+test_condition_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
 
 # relayd backward compat for groou-by-session utilities
 test_relayd_backward_compat_group_by_session_SOURCES = test_relayd_backward_compat_group_by_session.c
@@ -201,3 +215,7 @@ test_uuid_LDADD = $(LIBTAP) $(LIBCOMMON)
 # buffer view unit test
 test_buffer_view_SOURCES = test_buffer_view.c
 test_buffer_view_LDADD = $(LIBTAP) $(LIBCOMMON)
+
+# Event expression to bytecode test
+test_event_expr_to_bytecode_SOURCES = test_event_expr_to_bytecode.c
+test_event_expr_to_bytecode_LDADD = $(LIBTAP) $(LIBLTTNG_CTL) $(LIBCOMMON)
This page took 0.027809 seconds and 5 git commands to generate.