cpp-common/bt2: move findAllPluginsFromDir() to `plugin-load.hpp`
[babeltrace.git] / src / Makefile.am
index 5494041a703779830685bc2381c4517ab1fa1715..235dab4eb729d1f9d3f8aaae17e1301d9c50b815 100644 (file)
@@ -11,53 +11,6 @@ if ENABLE_PYTHON_BINDINGS
 SUBDIRS += bindings/python/bt2
 endif
 
-noinst_HEADERS = \
-       cpp-common/bt2/borrowed-object-iterator.hpp \
-       cpp-common/bt2/borrowed-object-proxy.hpp \
-       cpp-common/bt2/borrowed-object.hpp \
-       cpp-common/bt2/clock-class.hpp \
-       cpp-common/bt2/clock-snapshot.hpp \
-       cpp-common/bt2/component-port.hpp \
-       cpp-common/bt2/exc.hpp \
-       cpp-common/bt2/field-class.hpp \
-       cpp-common/bt2/field.hpp \
-       cpp-common/bt2/field-path.hpp \
-       cpp-common/bt2/integer-range.hpp \
-       cpp-common/bt2/integer-range-set.hpp \
-       cpp-common/bt2/internal/utils.hpp \
-       cpp-common/bt2/logging.hpp \
-       cpp-common/bt2/message-array.hpp \
-       cpp-common/bt2/message-iterator.hpp \
-       cpp-common/bt2/message.hpp \
-       cpp-common/bt2/shared-object.hpp \
-       cpp-common/bt2/raw-value-proxy.hpp \
-       cpp-common/bt2/self-component-port.hpp \
-       cpp-common/bt2/trace-ir.hpp \
-       cpp-common/bt2/type-traits.hpp \
-       cpp-common/bt2/value.hpp \
-       cpp-common/align.hpp \
-       cpp-common/cfg-error-reporting.hpp \
-       cpp-common/cfg-error-reporting-throw.hpp \
-       cpp-common/cfg-logging-error-reporting.hpp \
-       cpp-common/cfg-logging-error-reporting-throw.hpp \
-       cpp-common/cfg-logging.hpp \
-       cpp-common/endian.hpp \
-       cpp-common/exc.hpp \
-       cpp-common/glib-up.hpp \
-       cpp-common/libc-up.hpp \
-       cpp-common/lib-str.hpp \
-       cpp-common/log-cfg.hpp \
-       cpp-common/make-unique.hpp \
-       cpp-common/nlohmann/json.hpp \
-       cpp-common/optional.hpp \
-       cpp-common/read-fixed-len-int.hpp \
-       cpp-common/safe-ops.hpp \
-       cpp-common/std-int.hpp \
-       cpp-common/string_view.hpp \
-       cpp-common/uuid.hpp \
-       cpp-common/uuid-view.hpp \
-       cpp-common/vector.hpp
-
 ## This target generates an include file that contains the git version
 ## string of the current branch, it must be continuously updated when
 ## we build in the git repo and shipped in dist tarballs to reflect the
@@ -100,6 +53,8 @@ noinst_LTLIBRARIES = \
        autodisc/libautodisc.la \
        common/libcommon.la \
        compat/libcompat.la \
+       cpp-common/libcpp-common.la \
+       cpp-common/vendor/fmt/libfmt.la \
        ctfser/libctfser.la \
        fd-cache/libfd-cache.la \
        logging/liblogging.la \
@@ -156,6 +111,87 @@ compat_libcompat_la_SOURCES = \
        compat/unistd.h \
        compat/utc.h
 
+cpp_common_libcpp_common_la_SOURCES = \
+       cpp-common/bt2/borrowed-object-iterator.hpp \
+       cpp-common/bt2/borrowed-object-proxy.hpp \
+       cpp-common/bt2/borrowed-object.hpp \
+       cpp-common/bt2/clock-class.hpp \
+       cpp-common/bt2/clock-snapshot.hpp \
+       cpp-common/bt2/component-class-dev.hpp \
+       cpp-common/bt2/component-class.hpp \
+       cpp-common/bt2/component-port.hpp \
+       cpp-common/bt2/graph.hpp \
+       cpp-common/bt2/exc.hpp \
+       cpp-common/bt2/field-class.hpp \
+       cpp-common/bt2/field-path.hpp \
+       cpp-common/bt2/field.hpp \
+       cpp-common/bt2/integer-range-set.hpp \
+       cpp-common/bt2/integer-range.hpp \
+       cpp-common/bt2/internal/comp-cls-bridge.hpp \
+       cpp-common/bt2/internal/utils.hpp \
+       cpp-common/bt2/logging.hpp \
+       cpp-common/bt2/message-array.hpp \
+       cpp-common/bt2/message-iterator.hpp \
+       cpp-common/bt2/message.hpp \
+       cpp-common/bt2/optional-borrowed-object.hpp \
+       cpp-common/bt2/plugin-dev.hpp \
+       cpp-common/bt2/plugin-load.hpp \
+       cpp-common/bt2/plugin-set.hpp \
+       cpp-common/bt2/private-query-executor.hpp \
+       cpp-common/bt2/query-executor.hpp \
+       cpp-common/bt2/raw-value-proxy.hpp \
+       cpp-common/bt2/self-component-class.hpp \
+       cpp-common/bt2/self-component-port.hpp \
+       cpp-common/bt2/self-message-iterator-configuration.hpp \
+       cpp-common/bt2/self-message-iterator.hpp \
+       cpp-common/bt2/shared-object.hpp \
+       cpp-common/bt2/trace-ir.hpp \
+       cpp-common/bt2/type-traits.hpp \
+       cpp-common/bt2/value.hpp \
+       cpp-common/bt2/wrap.hpp \
+       cpp-common/bt2c/align.hpp \
+       cpp-common/bt2c/c-string-view.hpp \
+       cpp-common/bt2c/call.hpp \
+       cpp-common/bt2c/dummy.cpp \
+       cpp-common/bt2c/endian.hpp \
+       cpp-common/bt2c/exc.hpp \
+       cpp-common/bt2c/fmt.hpp \
+       cpp-common/bt2c/glib-up.hpp \
+       cpp-common/bt2c/libc-up.hpp \
+       cpp-common/bt2c/logging.hpp \
+       cpp-common/bt2c/prio-heap.hpp \
+       cpp-common/bt2c/read-fixed-len-int.hpp \
+       cpp-common/bt2c/safe-ops.hpp \
+       cpp-common/bt2c/std-int.hpp \
+       cpp-common/bt2c/type-traits.hpp \
+       cpp-common/bt2c/uuid.hpp \
+       cpp-common/bt2c/vector.hpp \
+       cpp-common/bt2s/make-unique.hpp \
+       cpp-common/bt2s/optional.hpp \
+       cpp-common/bt2s/span.hpp \
+       cpp-common/bt2s/string-view.hpp \
+       cpp-common/vendor/nlohmann/json.hpp \
+       cpp-common/vendor/optional-lite/optional.hpp \
+       cpp-common/vendor/span-lite/span.hpp \
+       cpp-common/vendor/string_view-standalone/string_view.hpp
+
+cpp_common_vendor_fmt_libfmt_la_SOURCES = \
+       cpp-common/vendor/fmt/args.h \
+       cpp-common/vendor/fmt/chrono.h \
+       cpp-common/vendor/fmt/color.h \
+       cpp-common/vendor/fmt/compile.h \
+       cpp-common/vendor/fmt/core.h \
+       cpp-common/vendor/fmt/format-inl.h \
+       cpp-common/vendor/fmt/format.cc \
+       cpp-common/vendor/fmt/format.h \
+       cpp-common/vendor/fmt/os.cc \
+       cpp-common/vendor/fmt/os.h \
+       cpp-common/vendor/fmt/ostream.h \
+       cpp-common/vendor/fmt/printf.h \
+       cpp-common/vendor/fmt/ranges.h \
+       cpp-common/vendor/fmt/std.h \
+       cpp-common/vendor/fmt/xchar.h
+
 ctfser_libctfser_la_SOURCES = \
        ctfser/ctfser.c \
        ctfser/ctfser.h
@@ -166,7 +202,8 @@ fd_cache_libfd_cache_la_SOURCES = \
 
 logging_liblogging_la_SOURCES = \
        logging/comp-logging.h \
-       logging/log.c \
+       logging/log-api.c \
+       logging/log-api.h \
        logging/log.h
 
 param_parse_libparam_parse_la_SOURCES = \
@@ -347,7 +384,6 @@ lib_libbabeltrace2_la_SOURCES = \
        lib/graph/message/event.h \
        lib/graph/message-iterator-class.c \
        lib/graph/message-iterator-class.h \
-       lib/graph/message/iterator.h \
        lib/graph/message/message.c \
        lib/graph/message/message.h \
        lib/graph/message/message-iterator-inactivity.c \
@@ -377,6 +413,7 @@ lib_libbabeltrace2_la_SOURCES = \
        lib/graph/interrupter.c \
        lib/graph/interrupter.h \
        lib/graph/iterator.c \
+       lib/graph/iterator.h \
        lib/graph/mip.c \
        lib/graph/port.c \
        lib/graph/port.h \
@@ -386,8 +423,6 @@ lib_libbabeltrace2_la_SOURCES = \
        lib/plugin/plugin.h \
        lib/plugin/plugin-so.c \
        lib/plugin/plugin-so.h \
-       lib/prio-heap/prio-heap.c \
-       lib/prio-heap/prio-heap.h \
        lib/trace-ir/attributes.c \
        lib/trace-ir/attributes.h \
        lib/trace-ir/clock-class.c \
@@ -570,11 +605,15 @@ plugins_utils_babeltrace_plugin_utils_la_SOURCES = \
        plugins/utils/counter/counter.h \
        plugins/utils/dummy/dummy.c \
        plugins/utils/dummy/dummy.h \
-       plugins/utils/muxer/muxer.c \
-       plugins/utils/muxer/muxer.h \
+       plugins/utils/muxer/comp.cpp \
+       plugins/utils/muxer/comp.hpp \
+       plugins/utils/muxer/msg-iter.cpp \
+       plugins/utils/muxer/msg-iter.hpp \
+       plugins/utils/muxer/upstream-msg-iter.cpp \
+       plugins/utils/muxer/upstream-msg-iter.hpp \
        plugins/utils/trimmer/trimmer.c \
        plugins/utils/trimmer/trimmer.h \
-       plugins/utils/plugin.c
+       plugins/utils/plugin.cpp
 
 plugins_utils_babeltrace_plugin_utils_la_LDFLAGS = \
        $(AM_LDFLAGS) \
@@ -588,6 +627,7 @@ if !ENABLE_BUILT_IN_PLUGINS
 plugins_utils_babeltrace_plugin_utils_la_LIBADD += \
        lib/libbabeltrace2.la \
        common/libcommon.la \
+       cpp-common/vendor/fmt/libfmt.la \
        logging/liblogging.la \
        plugins/common/param-validation/libparam-validation.la
 endif
@@ -713,4 +753,6 @@ plugins_lttng_utils_babeltrace_plugin_lttng_utils_la_LIBADD += \
 endif # !ENABLE_BUILT_IN_PLUGINS
 endif # ENABLE_DEBUG_INFO
 
-EXTRA_DIST = cpp-common/optional.hpp.license
+EXTRA_DIST = \
+       cpp-common/vendor/optional-lite/optional.hpp.license \
+       cpp-common/vendor/span-lite/span.hpp.license
This page took 0.02553 seconds and 4 git commands to generate.