build: factor out `pluginarchive` function to `src/Makefile.common.inc`
[babeltrace.git] / src / cli / Makefile.am
index 4731375b9295f7e45d308042c2b30f433d407b06..4525487809ef4f7fc8643708d8c52a5a1aef6c3e 100644 (file)
@@ -1,7 +1,8 @@
 # SPDX-FileCopyrightText: 2019-2023 EfficiOS, Inc.
 # SPDX-License-Identifier: MIT
 
-PLUGINS_PATH = $(abs_top_builddir)/src/plugins
+include $(top_srcdir)/src/Makefile.common.inc
+
 LTTNG_UTILS_PLUGIN_PATH =
 
 if ENABLE_DEBUG_INFO
@@ -69,21 +70,6 @@ babeltrace2_bin_LDADD = \
        $(top_builddir)/src/ctfser/libctfser.la
 
 if ENABLE_BUILT_IN_PLUGINS
-# Takes a plugin name and outputs the needed LDFLAGS to embed it.
-#
-# The --whole-archive option is important here. From the GNU linker's
-# documentation:
-#
-#     For each archive mentioned on the command line after the
-#     --whole-archive option, include every object file in the archive in
-#     the link, rather than searching the archive for the required object
-#     files.
-#
-# In our case, we find the plugins thanks to special sections in the
-# binary that are filled by plugin objects. If the linker discards those
-# symbols because the CLI does not use them directly, the CLI reports
-# no plugins found (plugins are effectively not embedded).
-pluginarchive = $(LD_WHOLE_ARCHIVE)$(PLUGINS_PATH)/$(1)/.libs/babeltrace-plugin-$(1).a$(LD_NO_WHOLE_ARCHIVE)
 
 # Built-in plugins
 babeltrace2_bin_LDFLAGS += $(call pluginarchive,ctf)
This page took 0.024804 seconds and 4 git commands to generate.