Silence -Wnull-dereference warning in generated CTF parser code
[babeltrace.git] / src / plugins / ctf / common / metadata / Makefile.am
index efbd50b91d9a32fae5a6f5d1776dde9afe67c15f..5a6e4deec75c021966ebcc67931c2194ee9a1dae 100644 (file)
@@ -10,7 +10,12 @@ libctf_parser_la_SOURCES = lexer.l parser.y objstack.c
 # with bt_.
 libctf_parser_la_CPPFLAGS = $(AM_CPPFLAGS) \
                -include $(srcdir)/scanner-symbols.h
-libctf_parser_la_CFLAGS = $(AM_CFLAGS) -Wno-unused-function
+
+# This library contains (mostly) generated code, silence some warnings that it
+# produces.
+libctf_parser_la_CFLAGS = $(AM_CFLAGS) \
+       -Wno-unused-function \
+       -Wno-null-dereference
 
 libctf_ast_la_SOURCES = \
        visitor-generate-ir.c \
This page took 0.024635 seconds and 4 git commands to generate.