Cleanup: Don't hardcode include paths unnecessarily
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index 1f8e76e3a0e80b9947e79289837a00f76294d2d3..cc67e9e03fb104ad45ff68d4b84b7f3e79f1a89a 100644 (file)
@@ -1,5 +1,5 @@
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include \
-               -I$(top_srcdir)/formats/ctf/metadata
+               -I$(srcdir)
 BUILT_SOURCES = ctf-parser.h
 AM_YFLAGS = -t -d -v
 
@@ -12,9 +12,12 @@ noinst_HEADERS = \
        objstack.h
 
 libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y objstack.c
-libctf_parser_la_CFLAGS = $(AM_CFLAGS)
+# ctf-scanner-symbols.h is included to prefix generated yy_* symbols
+# with bt_.
+libctf_parser_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir) \
+               -include $(srcdir)/ctf-scanner-symbols.h
 
-libctf_ast_la_CFLAGS = $(AM_CFLAGS) -I$(top_builddir)/formats/ctf/metadata
+libctf_ast_la_CFLAGS = $(AM_CFLAGS) -I$(builddir)
 libctf_ast_la_SOURCES = ctf-visitor-xml.c \
                ctf-visitor-parent-links.c \
                ctf-visitor-semantic-validator.c \
@@ -34,7 +37,7 @@ endif
 
 noinst_PROGRAMS = ctf-parser-test
 ctf_parser_test_SOURCES = ctf-parser-test.c
-ctf_parser_test_CFLAGS = $(AM_CFLAGS) -I$(top_builddir)/formats/ctf/metadata
+ctf_parser_test_CFLAGS = $(AM_CFLAGS) -I$(builddir)
 ctf_parser_test_LDADD = \
                libctf-parser.la \
                libctf-ast.la
This page took 0.028855 seconds and 4 git commands to generate.