Cleanup: Don't hardcode include paths unnecessarily
[babeltrace.git] / formats / ctf / metadata / Makefile.am
index b33ce5536b4124284100a52f1bc60c664987065a..cc67e9e03fb104ad45ff68d4b84b7f3e79f1a89a 100644 (file)
@@ -1,4 +1,5 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include \
+               -I$(srcdir)
 BUILT_SOURCES = ctf-parser.h
 AM_YFLAGS = -t -d -v
 
@@ -11,13 +12,16 @@ noinst_HEADERS = \
        objstack.h
 
 libctf_parser_la_SOURCES = ctf-lexer.l ctf-parser.y objstack.c
-libctf_parser_la_CFLAGS = $(AM_CFLAGS) -include ctf-scanner-symbols.h
+# ctf-scanner-symbols.h is included to prefix generated yy_* symbols
+# with bt_.
+libctf_parser_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir) \
+               -include $(srcdir)/ctf-scanner-symbols.h
 
+libctf_ast_la_CFLAGS = $(AM_CFLAGS) -I$(builddir)
 libctf_ast_la_SOURCES = ctf-visitor-xml.c \
                ctf-visitor-parent-links.c \
                ctf-visitor-semantic-validator.c \
                ctf-visitor-generate-io-struct.c
-
 libctf_ast_la_LIBADD = \
        $(top_builddir)/lib/libbabeltrace.la
 
@@ -27,10 +31,15 @@ endif
 if BABELTRACE_BUILD_WITH_LIBC_UUID
 libctf_ast_la_LIBADD += -lc
 endif
+if BABELTRACE_BUILD_WITH_MINGW
+libctf_ast_la_LIBADD += -lrpcrt4 -lintl -liconv -lole32 -lpopt
+endif
 
 noinst_PROGRAMS = ctf-parser-test
 ctf_parser_test_SOURCES = ctf-parser-test.c
-
+ctf_parser_test_CFLAGS = $(AM_CFLAGS) -I$(builddir)
 ctf_parser_test_LDADD = \
                libctf-parser.la \
                libctf-ast.la
+
+CLEANFILES = ctf-lexer.c ctf-parser.c ctf-parser.h ctf-parser.output
This page took 0.023896 seconds and 4 git commands to generate.