doc/api/libbabeltrace2/DoxygenLayout.xml: use `topics` tab
[babeltrace.git] / src / Makefile.am
index 2d18268ce6699c767200180c1b2faa93471b19b3..72a714639917b72780ee75115de709bb1ad39237 100644 (file)
@@ -109,7 +109,7 @@ compat_libcompat_la_SOURCES = \
        compat/memstream.h \
        compat/mman.c \
        compat/mman.h \
-       compat/socket.h \
+       compat/socket.hpp \
        compat/stdio.h \
        compat/stdlib.h \
        compat/string.h \
@@ -161,17 +161,19 @@ cpp_common_libcpp_common_la_SOURCES = \
        cpp-common/bt2c/c-string-view.hpp \
        cpp-common/bt2c/call.hpp \
        cpp-common/bt2c/contains.hpp \
-       cpp-common/bt2c/dummy.cpp \
+       cpp-common/bt2c/data-len.hpp \
        cpp-common/bt2c/endian.hpp \
        cpp-common/bt2c/exc.hpp \
+       cpp-common/bt2c/file-utils.cpp \
+       cpp-common/bt2c/file-utils.hpp \
        cpp-common/bt2c/fmt.hpp \
        cpp-common/bt2c/glib-up.hpp \
        cpp-common/bt2c/libc-up.hpp \
        cpp-common/bt2c/logging.hpp \
+       cpp-common/bt2c/make-span.hpp \
        cpp-common/bt2c/prio-heap.hpp \
        cpp-common/bt2c/read-fixed-len-int.hpp \
        cpp-common/bt2c/safe-ops.hpp \
-       cpp-common/bt2c/span.hpp \
        cpp-common/bt2c/std-int.hpp \
        cpp-common/bt2c/type-traits.hpp \
        cpp-common/bt2c/uuid.hpp \
@@ -183,7 +185,12 @@ cpp_common_libcpp_common_la_SOURCES = \
        cpp-common/vendor/nlohmann/json.hpp \
        cpp-common/vendor/optional-lite/optional.hpp \
        cpp-common/vendor/span-lite/span.hpp \
-       cpp-common/vendor/string-view-lite/string_view.hpp
+       cpp-common/vendor/string-view-lite/string_view.hpp \
+       cpp-common/vendor/wise-enum/optional.h \
+       cpp-common/vendor/wise-enum/optional_common.h \
+       cpp-common/vendor/wise-enum/wise_enum.h \
+       cpp-common/vendor/wise-enum/wise_enum_detail.h \
+       cpp-common/vendor/wise-enum/wise_enum_generated.h
 
 cpp_common_vendor_fmt_libfmt_la_SOURCES = \
        cpp-common/vendor/fmt/args.h \
@@ -202,6 +209,9 @@ cpp_common_vendor_fmt_libfmt_la_SOURCES = \
        cpp-common/vendor/fmt/std.h \
        cpp-common/vendor/fmt/xchar.h
 
+cpp_common_vendor_fmt_libfmt_la_CXXFLAGS = \
+       $(AM_CXXFLAGS) -Wno-missing-noreturn
+
 ctfser_libctfser_la_SOURCES = \
        ctfser/ctfser.c \
        ctfser/ctfser.h
@@ -243,14 +253,14 @@ AM_YFLAGS = \
        -t -d -v -Wno-yacc
 
 plugins_ctf_common_metadata_libctf_parser_la_SOURCES = \
-       plugins/ctf/common/metadata/lexer.lpp \
-       plugins/ctf/common/metadata/parser.ypp \
-       plugins/ctf/common/metadata/objstack.cpp
+       plugins/ctf/common/src/metadata/tsdl/lexer.lpp \
+       plugins/ctf/common/src/metadata/tsdl/parser.ypp \
+       plugins/ctf/common/src/metadata/tsdl/objstack.cpp
 
 # scanner-symbols.h is included to prefix generated yy_* symbols with bt_.
 plugins_ctf_common_metadata_libctf_parser_la_CPPFLAGS = \
        $(AM_CPPFLAGS) \
-       -include $(srcdir)/plugins/ctf/common/metadata/scanner-symbols.hpp
+       -include $(srcdir)/plugins/ctf/common/src/metadata/tsdl/scanner-symbols.hpp
 
 # This library contains (mostly) generated code, silence some warnings that it
 # produces.
@@ -262,52 +272,51 @@ plugins_ctf_common_metadata_libctf_parser_la_CXXFLAGS = \
        -Wno-unused-parameter
 
 plugins_ctf_common_metadata_libctf_ast_la_SOURCES = \
-       plugins/ctf/common/metadata/visitor-generate-ir.cpp \
-       plugins/ctf/common/metadata/visitor-semantic-validator.cpp \
-       plugins/ctf/common/metadata/visitor-parent-links.cpp \
-       plugins/ctf/common/metadata/ast.hpp \
-       plugins/ctf/common/metadata/objstack.hpp \
-       plugins/ctf/common/metadata/parser.hpp \
-       plugins/ctf/common/metadata/parser-wrap.hpp \
-       plugins/ctf/common/metadata/scanner.hpp \
-       plugins/ctf/common/metadata/scanner-symbols.hpp \
-       plugins/ctf/common/metadata/decoder.cpp \
-       plugins/ctf/common/metadata/decoder.hpp \
-       plugins/ctf/common/metadata/decoder-packetized-file-stream-to-buf.cpp \
-       plugins/ctf/common/metadata/decoder-packetized-file-stream-to-buf.hpp \
-       plugins/ctf/common/metadata/logging.cpp \
-       plugins/ctf/common/metadata/logging.hpp \
-       plugins/ctf/common/metadata/ctf-meta.hpp \
-       plugins/ctf/common/metadata/ctf-meta-visitors.hpp \
-       plugins/ctf/common/metadata/ctf-meta-validate.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-meanings.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-in-ir.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-default-clock-classes.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-text-array-sequence.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-alignments.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-value-storing-indexes.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-stream-class-config.cpp \
-       plugins/ctf/common/metadata/ctf-meta-warn-meaningless-header-fields.cpp \
-       plugins/ctf/common/metadata/ctf-meta-translate.cpp \
-       plugins/ctf/common/metadata/ctf-meta-resolve.cpp \
-       plugins/ctf/common/metadata/ctf-meta-configure-ir-trace.cpp \
-       plugins/ctf/common/metadata/ctf-meta-configure-ir-trace.hpp
+       plugins/ctf/common/src/metadata/tsdl/visitor-generate-ir.cpp \
+       plugins/ctf/common/src/metadata/tsdl/visitor-semantic-validator.cpp \
+       plugins/ctf/common/src/metadata/tsdl/visitor-parent-links.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ast.hpp \
+       plugins/ctf/common/src/metadata/tsdl/objstack.hpp \
+       plugins/ctf/common/src/metadata/tsdl/parser.hpp \
+       plugins/ctf/common/src/metadata/tsdl/parser-wrap.hpp \
+       plugins/ctf/common/src/metadata/tsdl/scanner.hpp \
+       plugins/ctf/common/src/metadata/tsdl/scanner-symbols.hpp \
+       plugins/ctf/common/src/metadata/tsdl/decoder.cpp \
+       plugins/ctf/common/src/metadata/tsdl/decoder.hpp \
+       plugins/ctf/common/src/metadata/tsdl/decoder-packetized-file-stream-to-buf.cpp \
+       plugins/ctf/common/src/metadata/tsdl/decoder-packetized-file-stream-to-buf.hpp \
+       plugins/ctf/common/src/metadata/tsdl/logging.hpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta.hpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-visitors.hpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-validate.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-meanings.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-in-ir.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-default-clock-classes.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-text-array-sequence.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-alignments.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-value-storing-indexes.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-stream-class-config.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-warn-meaningless-header-fields.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-translate.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-resolve.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-configure-ir-trace.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-configure-ir-trace.hpp
 
 if BABELTRACE_BUILD_WITH_MINGW
 plugins_ctf_common_metadata_libctf_ast_la_LIBADD = -lintl -liconv -lole32
 endif
 
 BUILT_SOURCES += \
-       plugins/ctf/common/metadata/parser.hpp
+       plugins/ctf/common/src/metadata/tsdl/parser.hpp
 
 ALL_LOCAL =
 
 if HAVE_BISON
 # We have bison: we can clean the generated parser files
 CLEANFILES += \
-       plugins/ctf/common/metadata/parser.cpp \
-       plugins/ctf/common/metadata/parser.hpp \
-       plugins/ctf/common/metadata/parser.output
+       plugins/ctf/common/src/metadata/tsdl/parser.cpp \
+       plugins/ctf/common/src/metadata/tsdl/parser.hpp \
+       plugins/ctf/common/src/metadata/tsdl/parser.output
 else # HAVE_BISON
 # Create target used to stop the build if we want to build the parser,
 # but we don't have the necessary tool to do so
@@ -648,11 +657,11 @@ endif
 
 # ctf plugin
 plugins_ctf_babeltrace_plugin_ctf_la_SOURCES = \
-       plugins/ctf/common/bfcr/bfcr.cpp \
-       plugins/ctf/common/bfcr/bfcr.hpp \
-       plugins/ctf/common/msg-iter/msg-iter.cpp \
-       plugins/ctf/common/msg-iter/msg-iter.hpp \
-       plugins/ctf/common/print.hpp \
+       plugins/ctf/common/src/bfcr/bfcr.cpp \
+       plugins/ctf/common/src/bfcr/bfcr.hpp \
+       plugins/ctf/common/src/clk-cls-cfg.hpp \
+       plugins/ctf/common/src/msg-iter/msg-iter.cpp \
+       plugins/ctf/common/src/msg-iter/msg-iter.hpp \
        plugins/ctf/fs-sink/fs-sink.cpp \
        plugins/ctf/fs-sink/fs-sink-ctf-meta.hpp \
        plugins/ctf/fs-sink/fs-sink.hpp \
@@ -706,7 +715,8 @@ plugins_ctf_babeltrace_plugin_ctf_la_LIBADD += \
        logging/liblogging.la \
        plugins/common/muxing/libmuxing.la \
        common/libcommon.la \
-       ctfser/libctfser.la
+       ctfser/libctfser.la \
+       cpp-common/vendor/fmt/libfmt.la
 endif
 
 # text plugin
This page took 0.025502 seconds and 4 git commands to generate.