doc/api/libbabeltrace2/DoxygenLayout.xml: use `topics` tab
[babeltrace.git] / src / Makefile.am
index 873ccf8560a32058f3243393e294c3d6106b6232..72a714639917b72780ee75115de709bb1ad39237 100644 (file)
@@ -51,6 +51,7 @@ DISTCLEANFILES = common/version.i
 noinst_LTLIBRARIES = \
        argpar/libargpar.la \
        autodisc/libautodisc.la \
+       clock-correlation-validator/libclock-correlation-validator.la \
        common/libcommon.la \
        compat/libcompat.la \
        cpp-common/libcpp-common.la \
@@ -74,6 +75,11 @@ autodisc_libautodisc_la_SOURCES = \
        autodisc/autodisc.c \
        autodisc/autodisc.h
 
+clock_correlation_validator_libclock_correlation_validator_la_SOURCES = \
+       clock-correlation-validator/clock-correlation-validator.cpp \
+       clock-correlation-validator/clock-correlation-validator.h \
+       clock-correlation-validator/clock-correlation-validator.hpp
+
 common_libcommon_la_SOURCES = \
        common/align.h \
        common/assert.c \
@@ -103,7 +109,7 @@ compat_libcompat_la_SOURCES = \
        compat/memstream.h \
        compat/mman.c \
        compat/mman.h \
-       compat/socket.h \
+       compat/socket.hpp \
        compat/stdio.h \
        compat/stdlib.h \
        compat/string.h \
@@ -121,6 +127,7 @@ cpp_common_libcpp_common_la_SOURCES = \
        cpp-common/bt2/component-class.hpp \
        cpp-common/bt2/component-port.hpp \
        cpp-common/bt2/graph.hpp \
+       cpp-common/bt2/error.hpp \
        cpp-common/bt2/exc.hpp \
        cpp-common/bt2/field-class.hpp \
        cpp-common/bt2/field-path.hpp \
@@ -135,6 +142,7 @@ cpp_common_libcpp_common_la_SOURCES = \
        cpp-common/bt2/message.hpp \
        cpp-common/bt2/optional-borrowed-object.hpp \
        cpp-common/bt2/plugin-dev.hpp \
+       cpp-common/bt2/plugin-load.hpp \
        cpp-common/bt2/plugin-set.hpp \
        cpp-common/bt2/plugin.hpp \
        cpp-common/bt2/private-query-executor.hpp \
@@ -152,13 +160,17 @@ cpp_common_libcpp_common_la_SOURCES = \
        cpp-common/bt2c/align.hpp \
        cpp-common/bt2c/c-string-view.hpp \
        cpp-common/bt2c/call.hpp \
-       cpp-common/bt2c/dummy.cpp \
+       cpp-common/bt2c/contains.hpp \
+       cpp-common/bt2c/data-len.hpp \
        cpp-common/bt2c/endian.hpp \
        cpp-common/bt2c/exc.hpp \
+       cpp-common/bt2c/file-utils.cpp \
+       cpp-common/bt2c/file-utils.hpp \
        cpp-common/bt2c/fmt.hpp \
        cpp-common/bt2c/glib-up.hpp \
        cpp-common/bt2c/libc-up.hpp \
        cpp-common/bt2c/logging.hpp \
+       cpp-common/bt2c/make-span.hpp \
        cpp-common/bt2c/prio-heap.hpp \
        cpp-common/bt2c/read-fixed-len-int.hpp \
        cpp-common/bt2c/safe-ops.hpp \
@@ -173,7 +185,12 @@ cpp_common_libcpp_common_la_SOURCES = \
        cpp-common/vendor/nlohmann/json.hpp \
        cpp-common/vendor/optional-lite/optional.hpp \
        cpp-common/vendor/span-lite/span.hpp \
-       cpp-common/vendor/string_view-standalone/string_view.hpp
+       cpp-common/vendor/string-view-lite/string_view.hpp \
+       cpp-common/vendor/wise-enum/optional.h \
+       cpp-common/vendor/wise-enum/optional_common.h \
+       cpp-common/vendor/wise-enum/wise_enum.h \
+       cpp-common/vendor/wise-enum/wise_enum_detail.h \
+       cpp-common/vendor/wise-enum/wise_enum_generated.h
 
 cpp_common_vendor_fmt_libfmt_la_SOURCES = \
        cpp-common/vendor/fmt/args.h \
@@ -192,6 +209,9 @@ cpp_common_vendor_fmt_libfmt_la_SOURCES = \
        cpp-common/vendor/fmt/std.h \
        cpp-common/vendor/fmt/xchar.h
 
+cpp_common_vendor_fmt_libfmt_la_CXXFLAGS = \
+       $(AM_CXXFLAGS) -Wno-missing-noreturn
+
 ctfser_libctfser_la_SOURCES = \
        ctfser/ctfser.c \
        ctfser/ctfser.h
@@ -233,14 +253,14 @@ AM_YFLAGS = \
        -t -d -v -Wno-yacc
 
 plugins_ctf_common_metadata_libctf_parser_la_SOURCES = \
-       plugins/ctf/common/metadata/lexer.lpp \
-       plugins/ctf/common/metadata/parser.ypp \
-       plugins/ctf/common/metadata/objstack.cpp
+       plugins/ctf/common/src/metadata/tsdl/lexer.lpp \
+       plugins/ctf/common/src/metadata/tsdl/parser.ypp \
+       plugins/ctf/common/src/metadata/tsdl/objstack.cpp
 
 # scanner-symbols.h is included to prefix generated yy_* symbols with bt_.
 plugins_ctf_common_metadata_libctf_parser_la_CPPFLAGS = \
        $(AM_CPPFLAGS) \
-       -include $(srcdir)/plugins/ctf/common/metadata/scanner-symbols.hpp
+       -include $(srcdir)/plugins/ctf/common/src/metadata/tsdl/scanner-symbols.hpp
 
 # This library contains (mostly) generated code, silence some warnings that it
 # produces.
@@ -252,52 +272,51 @@ plugins_ctf_common_metadata_libctf_parser_la_CXXFLAGS = \
        -Wno-unused-parameter
 
 plugins_ctf_common_metadata_libctf_ast_la_SOURCES = \
-       plugins/ctf/common/metadata/visitor-generate-ir.cpp \
-       plugins/ctf/common/metadata/visitor-semantic-validator.cpp \
-       plugins/ctf/common/metadata/visitor-parent-links.cpp \
-       plugins/ctf/common/metadata/ast.hpp \
-       plugins/ctf/common/metadata/objstack.hpp \
-       plugins/ctf/common/metadata/parser.hpp \
-       plugins/ctf/common/metadata/parser-wrap.hpp \
-       plugins/ctf/common/metadata/scanner.hpp \
-       plugins/ctf/common/metadata/scanner-symbols.hpp \
-       plugins/ctf/common/metadata/decoder.cpp \
-       plugins/ctf/common/metadata/decoder.hpp \
-       plugins/ctf/common/metadata/decoder-packetized-file-stream-to-buf.cpp \
-       plugins/ctf/common/metadata/decoder-packetized-file-stream-to-buf.hpp \
-       plugins/ctf/common/metadata/logging.cpp \
-       plugins/ctf/common/metadata/logging.hpp \
-       plugins/ctf/common/metadata/ctf-meta.hpp \
-       plugins/ctf/common/metadata/ctf-meta-visitors.hpp \
-       plugins/ctf/common/metadata/ctf-meta-validate.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-meanings.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-in-ir.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-default-clock-classes.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-text-array-sequence.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-alignments.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-value-storing-indexes.cpp \
-       plugins/ctf/common/metadata/ctf-meta-update-stream-class-config.cpp \
-       plugins/ctf/common/metadata/ctf-meta-warn-meaningless-header-fields.cpp \
-       plugins/ctf/common/metadata/ctf-meta-translate.cpp \
-       plugins/ctf/common/metadata/ctf-meta-resolve.cpp \
-       plugins/ctf/common/metadata/ctf-meta-configure-ir-trace.cpp \
-       plugins/ctf/common/metadata/ctf-meta-configure-ir-trace.hpp
+       plugins/ctf/common/src/metadata/tsdl/visitor-generate-ir.cpp \
+       plugins/ctf/common/src/metadata/tsdl/visitor-semantic-validator.cpp \
+       plugins/ctf/common/src/metadata/tsdl/visitor-parent-links.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ast.hpp \
+       plugins/ctf/common/src/metadata/tsdl/objstack.hpp \
+       plugins/ctf/common/src/metadata/tsdl/parser.hpp \
+       plugins/ctf/common/src/metadata/tsdl/parser-wrap.hpp \
+       plugins/ctf/common/src/metadata/tsdl/scanner.hpp \
+       plugins/ctf/common/src/metadata/tsdl/scanner-symbols.hpp \
+       plugins/ctf/common/src/metadata/tsdl/decoder.cpp \
+       plugins/ctf/common/src/metadata/tsdl/decoder.hpp \
+       plugins/ctf/common/src/metadata/tsdl/decoder-packetized-file-stream-to-buf.cpp \
+       plugins/ctf/common/src/metadata/tsdl/decoder-packetized-file-stream-to-buf.hpp \
+       plugins/ctf/common/src/metadata/tsdl/logging.hpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta.hpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-visitors.hpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-validate.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-meanings.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-in-ir.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-default-clock-classes.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-text-array-sequence.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-alignments.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-value-storing-indexes.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-update-stream-class-config.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-warn-meaningless-header-fields.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-translate.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-resolve.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-configure-ir-trace.cpp \
+       plugins/ctf/common/src/metadata/tsdl/ctf-meta-configure-ir-trace.hpp
 
 if BABELTRACE_BUILD_WITH_MINGW
 plugins_ctf_common_metadata_libctf_ast_la_LIBADD = -lintl -liconv -lole32
 endif
 
 BUILT_SOURCES += \
-       plugins/ctf/common/metadata/parser.hpp
+       plugins/ctf/common/src/metadata/tsdl/parser.hpp
 
 ALL_LOCAL =
 
 if HAVE_BISON
 # We have bison: we can clean the generated parser files
 CLEANFILES += \
-       plugins/ctf/common/metadata/parser.cpp \
-       plugins/ctf/common/metadata/parser.hpp \
-       plugins/ctf/common/metadata/parser.output
+       plugins/ctf/common/src/metadata/tsdl/parser.cpp \
+       plugins/ctf/common/src/metadata/tsdl/parser.hpp \
+       plugins/ctf/common/src/metadata/tsdl/parser.output
 else # HAVE_BISON
 # Create target used to stop the build if we want to build the parser,
 # but we don't have the necessary tool to do so
@@ -488,7 +507,10 @@ lib_libbabeltrace2_la_CPPFLAGS = \
 lib_libbabeltrace2_la_LIBADD = \
        logging/liblogging.la \
        common/libcommon.la \
-       compat/libcompat.la
+       compat/libcompat.la \
+       clock-correlation-validator/libclock-correlation-validator.la
+
+nodist_EXTRA_lib_libbabeltrace2_la_SOURCES = dummy.cpp
 
 ctf_writer_libbabeltrace2_ctf_writer_la_SOURCES = \
        ctf-writer/assert-pre.h \
@@ -629,16 +651,17 @@ plugins_utils_babeltrace_plugin_utils_la_LIBADD += \
        common/libcommon.la \
        cpp-common/vendor/fmt/libfmt.la \
        logging/liblogging.la \
-       plugins/common/param-validation/libparam-validation.la
+       plugins/common/param-validation/libparam-validation.la \
+       clock-correlation-validator/libclock-correlation-validator.la
 endif
 
 # ctf plugin
 plugins_ctf_babeltrace_plugin_ctf_la_SOURCES = \
-       plugins/ctf/common/bfcr/bfcr.cpp \
-       plugins/ctf/common/bfcr/bfcr.hpp \
-       plugins/ctf/common/msg-iter/msg-iter.cpp \
-       plugins/ctf/common/msg-iter/msg-iter.hpp \
-       plugins/ctf/common/print.hpp \
+       plugins/ctf/common/src/bfcr/bfcr.cpp \
+       plugins/ctf/common/src/bfcr/bfcr.hpp \
+       plugins/ctf/common/src/clk-cls-cfg.hpp \
+       plugins/ctf/common/src/msg-iter/msg-iter.cpp \
+       plugins/ctf/common/src/msg-iter/msg-iter.hpp \
        plugins/ctf/fs-sink/fs-sink.cpp \
        plugins/ctf/fs-sink/fs-sink-ctf-meta.hpp \
        plugins/ctf/fs-sink/fs-sink.hpp \
@@ -692,7 +715,8 @@ plugins_ctf_babeltrace_plugin_ctf_la_LIBADD += \
        logging/liblogging.la \
        plugins/common/muxing/libmuxing.la \
        common/libcommon.la \
-       ctfser/libctfser.la
+       ctfser/libctfser.la \
+       cpp-common/vendor/fmt/libfmt.la
 endif
 
 # text plugin
@@ -755,4 +779,5 @@ endif # ENABLE_DEBUG_INFO
 
 EXTRA_DIST = \
        cpp-common/vendor/optional-lite/optional.hpp.license \
-       cpp-common/vendor/span-lite/span.hpp.license
+       cpp-common/vendor/span-lite/span.hpp.license \
+       cpp-common/vendor/string-view-lite/string_view.hpp.license
This page took 0.026249 seconds and 4 git commands to generate.