doc/api/libbabeltrace2/DoxygenLayout.xml: use `topics` tab
[babeltrace.git] / src / Makefile.am
index b8eebe9fc9f4b9d35e8409feea5f47ba25e1f26c..72a714639917b72780ee75115de709bb1ad39237 100644 (file)
@@ -109,7 +109,7 @@ compat_libcompat_la_SOURCES = \
        compat/memstream.h \
        compat/mman.c \
        compat/mman.h \
-       compat/socket.h \
+       compat/socket.hpp \
        compat/stdio.h \
        compat/stdlib.h \
        compat/string.h \
@@ -161,17 +161,19 @@ cpp_common_libcpp_common_la_SOURCES = \
        cpp-common/bt2c/c-string-view.hpp \
        cpp-common/bt2c/call.hpp \
        cpp-common/bt2c/contains.hpp \
-       cpp-common/bt2c/dummy.cpp \
+       cpp-common/bt2c/data-len.hpp \
        cpp-common/bt2c/endian.hpp \
        cpp-common/bt2c/exc.hpp \
+       cpp-common/bt2c/file-utils.cpp \
+       cpp-common/bt2c/file-utils.hpp \
        cpp-common/bt2c/fmt.hpp \
        cpp-common/bt2c/glib-up.hpp \
        cpp-common/bt2c/libc-up.hpp \
        cpp-common/bt2c/logging.hpp \
+       cpp-common/bt2c/make-span.hpp \
        cpp-common/bt2c/prio-heap.hpp \
        cpp-common/bt2c/read-fixed-len-int.hpp \
        cpp-common/bt2c/safe-ops.hpp \
-       cpp-common/bt2c/span.hpp \
        cpp-common/bt2c/std-int.hpp \
        cpp-common/bt2c/type-traits.hpp \
        cpp-common/bt2c/uuid.hpp \
@@ -183,7 +185,12 @@ cpp_common_libcpp_common_la_SOURCES = \
        cpp-common/vendor/nlohmann/json.hpp \
        cpp-common/vendor/optional-lite/optional.hpp \
        cpp-common/vendor/span-lite/span.hpp \
-       cpp-common/vendor/string-view-lite/string_view.hpp
+       cpp-common/vendor/string-view-lite/string_view.hpp \
+       cpp-common/vendor/wise-enum/optional.h \
+       cpp-common/vendor/wise-enum/optional_common.h \
+       cpp-common/vendor/wise-enum/wise_enum.h \
+       cpp-common/vendor/wise-enum/wise_enum_detail.h \
+       cpp-common/vendor/wise-enum/wise_enum_generated.h
 
 cpp_common_vendor_fmt_libfmt_la_SOURCES = \
        cpp-common/vendor/fmt/args.h \
@@ -202,6 +209,9 @@ cpp_common_vendor_fmt_libfmt_la_SOURCES = \
        cpp-common/vendor/fmt/std.h \
        cpp-common/vendor/fmt/xchar.h
 
+cpp_common_vendor_fmt_libfmt_la_CXXFLAGS = \
+       $(AM_CXXFLAGS) -Wno-missing-noreturn
+
 ctfser_libctfser_la_SOURCES = \
        ctfser/ctfser.c \
        ctfser/ctfser.h
@@ -275,7 +285,6 @@ plugins_ctf_common_metadata_libctf_ast_la_SOURCES = \
        plugins/ctf/common/src/metadata/tsdl/decoder.hpp \
        plugins/ctf/common/src/metadata/tsdl/decoder-packetized-file-stream-to-buf.cpp \
        plugins/ctf/common/src/metadata/tsdl/decoder-packetized-file-stream-to-buf.hpp \
-       plugins/ctf/common/src/metadata/tsdl/logging.cpp \
        plugins/ctf/common/src/metadata/tsdl/logging.hpp \
        plugins/ctf/common/src/metadata/tsdl/ctf-meta.hpp \
        plugins/ctf/common/src/metadata/tsdl/ctf-meta-visitors.hpp \
@@ -650,6 +659,7 @@ endif
 plugins_ctf_babeltrace_plugin_ctf_la_SOURCES = \
        plugins/ctf/common/src/bfcr/bfcr.cpp \
        plugins/ctf/common/src/bfcr/bfcr.hpp \
+       plugins/ctf/common/src/clk-cls-cfg.hpp \
        plugins/ctf/common/src/msg-iter/msg-iter.cpp \
        plugins/ctf/common/src/msg-iter/msg-iter.hpp \
        plugins/ctf/fs-sink/fs-sink.cpp \
@@ -705,7 +715,8 @@ plugins_ctf_babeltrace_plugin_ctf_la_LIBADD += \
        logging/liblogging.la \
        plugins/common/muxing/libmuxing.la \
        common/libcommon.la \
-       ctfser/libctfser.la
+       ctfser/libctfser.la \
+       cpp-common/vendor/fmt/libfmt.la
 endif
 
 # text plugin
This page took 0.024142 seconds and 4 git commands to generate.