Tests: add unit tests for so_info
[babeltrace.git] / tests / Makefile.am
index 1038535e77d014fc0d9ebd9b4e5699354c269a27..56e93c115ab213f74943a59059ef30a457c0f7e5 100644 (file)
@@ -1,7 +1,30 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-noinst_PROGRAMS = test-bitfield test-dummytrace
+EXTRA_DIST = $(srcdir)/ctf-traces/** tests
+if ENABLE_DEBUGINFO
+EXTRA_DIST += $(srcdir)/debuginfo-data/** tests_debuginfo
+endif
 
-test_bitfield_SOURCES = test-bitfield.c
+SCRIPT_LIST = run.sh
 
-test_dummytrace_SOURCES = test-dummytrace.c
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+
+check-am:
+       ./run.sh $(srcdir)/tests
+if ENABLE_DEBUGINFO
+       ./run.sh $(srcdir)/tests_debuginfo
+endif
This page took 0.02289 seconds and 4 git commands to generate.