Tests: add unit tests for so_info
[babeltrace.git] / tests / Makefile.am
index c0ea34e66a90847341e34bffccaef50fb707658d..56e93c115ab213f74943a59059ef30a457c0f7e5 100644 (file)
@@ -1,6 +1,30 @@
 SUBDIRS = utils bin lib
 
-EXTRA_DIST = ctf-traces/**
+EXTRA_DIST = $(srcdir)/ctf-traces/** tests
+if ENABLE_DEBUGINFO
+EXTRA_DIST += $(srcdir)/debuginfo-data/** tests_debuginfo
+endif
+
+SCRIPT_LIST = run.sh
+
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 check-am:
-       ./run.sh tests
+       ./run.sh $(srcdir)/tests
+if ENABLE_DEBUGINFO
+       ./run.sh $(srcdir)/tests_debuginfo
+endif
This page took 0.022684 seconds and 4 git commands to generate.