Tests: add unit tests for bt_dwarf
[babeltrace.git] / tests / Makefile.am
index cf68aace63ecb6d7dbc9b5b25db933ddfbe1072c..56e93c115ab213f74943a59059ef30a457c0f7e5 100644 (file)
@@ -1,8 +1,30 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-SUBDIRS = utils lib
+EXTRA_DIST = $(srcdir)/ctf-traces/** tests
+if ENABLE_DEBUGINFO
+EXTRA_DIST += $(srcdir)/debuginfo-data/** tests_debuginfo
+endif
 
-EXTRA_DIST = runall.sh ctf-traces/**
+SCRIPT_LIST = run.sh
+
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 check-am:
-       ./runall.sh
+       ./run.sh $(srcdir)/tests
+if ENABLE_DEBUGINFO
+       ./run.sh $(srcdir)/tests_debuginfo
+endif
This page took 0.022938 seconds and 4 git commands to generate.