Fix: include ctf-scanner-symbols.h to prefix yy_* symbols
[babeltrace.git] / tests / Makefile.am
index 47891e90af0945d3accf10f7d3cd0fe1351af031..8d84b16b8db3e90595868130ea19de89312d88e6 100644 (file)
@@ -1,12 +1,24 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-SUBDIRS = lib
+EXTRA_DIST = ctf-traces/** tests
 
-noinst_PROGRAMS = test-bitfield
+SCRIPT_LIST = run.sh
 
-test_bitfield_SOURCES = test-bitfield.c
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
-EXTRA_DIST = runall.sh ctf-traces/**
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 check-am:
-       ./runall.sh
+       ./run.sh tests
This page took 0.023677 seconds and 4 git commands to generate.