Fix: include ctf-scanner-symbols.h to prefix yy_* symbols
[babeltrace.git] / tests / Makefile.am
index 816fa6600c82dac5e6bcd5340fd5c5e2914a7e19..8d84b16b8db3e90595868130ea19de89312d88e6 100644 (file)
@@ -1,8 +1,24 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-SUBDIRS = lib
+EXTRA_DIST = ctf-traces/** tests
 
-EXTRA_DIST = runall.sh ctf-traces/**
+SCRIPT_LIST = run.sh
+
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 check-am:
-       ./runall.sh
+       ./run.sh tests
This page took 0.02449 seconds and 4 git commands to generate.