Fix: include ctf-scanner-symbols.h to prefix yy_* symbols
[babeltrace.git] / tests / Makefile.am
index ffb41343ed1385a769c4f4b9c358cecd2e2f6792..8d84b16b8db3e90595868130ea19de89312d88e6 100644 (file)
@@ -1,10 +1,24 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-noinst_PROGRAMS = test-bitfield
+EXTRA_DIST = ctf-traces/** tests
 
-test_bitfield_SOURCES = test-bitfield.c
+SCRIPT_LIST = run.sh
 
-EXTRA_DIST = runall.sh
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 check-am:
-       ./runall.sh
+       ./run.sh tests
This page took 0.023827 seconds and 4 git commands to generate.