Tests: no substitution needed for multi-trace intersection test
[babeltrace.git] / tests / Makefile.am
index 583f7ac6e7e9b6c2480e9c12698684efbaf49fbf..98c7473c02b42b7ca3ac9b6f2e3b1cd67135790d 100644 (file)
@@ -1,12 +1,27 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+SUBDIRS = utils bin lib
 
-noinst_PROGRAMS = test-bitfield test-dummytrace
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
-test_bitfield_SOURCES = test-bitfield.c
+TESTS = bin/test_trace_read \
+       bin/test_trace_read \
+       bin/test_packet_seq_num \
+       bin/intersection/test_intersection \
+       lib/test_bitfield \
+       lib/test_seek_empty_packet \
+       lib/test_seek_big_trace \
+       lib/test_ctf_writer_complete
 
-test_dummytrace_SOURCES = test-dummytrace.c
+EXTRA_DIST = $(srcdir)/ctf-traces/** \
+            $(srcdir)/debug-info-data/** \
+            $(srcdir)/debug-info-data/.build-id/cd/**
 
+if ENABLE_DEBUG_INFO
+TESTS += lib/test_dwarf_complete \
+       lib/test_bin_info_complete
+endif
 
-test_dummytrace_LDADD = \
-       $(top_builddir)/formats/libbabeltrace_registry.la \
-       $(top_builddir)/formats/ctf/libctf.la
+if USE_PYTHON
+TESTS += bin/intersection/test_multi_trace_intersection.py
+endif
This page took 0.024137 seconds and 4 git commands to generate.